Question & Answer
Question
Why is the Monitor column with the toggle switches to enable or disable agent monitoring on the Agent analytics page missing when agent monitoring is enabled?
Cause
When agent monitoring is enabled, we expect to see the Monitor column on the Agent analytics page. For example:

The Monitor column is not available on Premium Agentic with Data Isolation plans. Server logs show an error similar to this example:
{
"time": "2026-04-19 13:47:44,047",
"level": "ERROR",
"message": "Monitoring status check failed for agent: 11646086-097a-48e6-xxx-yyy, with error: Monitoring is disabled for isolated tenants, Traceback: Traceback (most recent call last):\n File "/app/wo_archer/observability/routers/agent_monitoring.py", line 198, in get_agent_monitoring_status\n raise MonitoringServiceException("Monitoring is disabled for isolated tenants")\nwo_archer.observability.exceptions.MonitoringServiceException: Monitoring is disabled for isolated tenants\n",
"module": "agent_monitoring",
"filename": "agent_monitoring.py",
...
}
Answer
Check your subscription type. This is a Premium Agentic with Data Isolation plan:

Data Isolation is configured when the tenant is created. If you want to remove data isolation from your environment, then create a new watsonx Orchestrate Premium tenant, and move your current environment to it.
watsonx Orchestrate documentation reference:
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Document Information
Modified date:
04 May 2026
UID
ibm17271695