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ServiceNow Connector Failing with 403 Forbidden Error

Question & Answer


Question

ServiceNow connector is getting the error. Data is not getting loaded in to TBM Studio.

Error Message: Fails with error: Error Code: 403 : Error message received from Http Server, Code 403: Forbidden Details : User Not Authorized. Possible Solution : Grant required roles to user to access the table or check ACL restriction on table.

Cause

The issue occurs due to a mismatch in OAuth grant types between Datalink Financials and ServiceNow configuration:
In Datalink (ServiceNow Connector), the configuration uses Authorization Code Grant Type.

The ServiceNow connector in Datalink Financials does not support Client Credentials Grant Type. This mismatch results in a 403 Forbidden (Unauthorized) error when accessing tables.

Answer

Option 1: Use Authorization Code Grant Type (Recommended)

To use the ServiceNow connector:

Configure OAuth in ServiceNow using Authorization Code Grant Type
Update the connector configuration in Datalink to match:
Client ID
Client Secret
Authorization URL
Token URL
Re-authenticate the connector
Re-run the connector
 

Option 2: Use REST 2.0 Connector (Alternative)

If Client Credentials Grant Type is required:

Use the REST 2.0 connector instead of the ServiceNow connector
Configure OAuth using Client Credentials in REST connector
Provide API endpoints for required tables

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSSOGY","label":"IBM Apptio"},"ARM Category":[{"code":"a8mKe000000XZIQIA4","label":"Datalink Financials"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":""}]

Document Information

Modified date:
04 May 2026

UID

ibm17269906