IBM Support

Maximo Mobile for EAM Techmobile RBA app returns 404 error

Troubleshooting


Problem

In Maximo 7.6.1.3 with IBM Maximo Mobile 9.0, the Technicians application fails to load, displaying a '404 Not Found' error. 

The issue occurs in a Windows Server 2019 environment with WebSphere Application Server 8.5.5.24. 

Logs indicate a 'java.io.FileNotFoundException' related to the 'techmobile' application in the 'maximo/maf/techmobile/9.0.0.0-0/index.html' path.

Symptom

The Mobile Technician application in Maximo 7.6.1.3 is not accessible, displaying a '404 - Not Found' error when attempting to open it. 

The issue is specific to the Techmobile application, as other mobile applications like Inspection works correctly.

Cause

The issue is caused by Graphite failing to expand the Techmobile app due to a missing index.html file in the MAF directory.

 

Environment

Maximo 7.6.13 with Mobile 9.0

Diagnosing The Problem

- Check Maximo logs for errors related to the Techmobile application in Maximo:

[7/16/25 17:39:21:010 UTC] SystemOut - [WARN] [MXServer) [CID-MXOSLC-51687] Graphite Server Request failed
java.io.FileNotFoundException: F:\IBM\WebSphere\AppServer\profiles\ctgAppSrv01\MeaGlobalDirs\maximo\maf\techmobile\9.0.0.0-0\index.html
at com.ibm.iot.maximo.FileResourceLoader.verifyPath (FileResourceLoader.java:153)
at com.ibm.iot.maximo.FileResourceLoader.getResourceFile (FileResourceLoader.java:121) -[businessobjects.jar:?] 
at com.ibm.iot.maximo.FileResourceLoader.getResourceAsBytes(FileResourceLoader.java:88) -[businessobjects.jar:?]
at com.ibm.iot.maximo.GraphiteServer.getResource (GraphiteServer.java:76) [businessobjects.jar:?]
at com.ibm.tivoli.maximo.oslc.provider.GraphiteRouteHandler.doGraphiteRequest (GraphiteRouteHandler.java:381) [businessobjects.jar:?]
at com.ibm.tivoli.maximo.oslc.provider.GraphiteRouteHandler.handleRequest (GraphiteRouteHandler.java:466) [businessobjects.jar:?]
at com.ibm.tivoli.maximo.oslc.provider.Maximo0slcProviderServlet.handleRoute (Maximo0slcProviderServlet.java:1310) [commonweb-jar:?]|
at com.ibm.tivoli.maximo.oslc.provider.Maximo0slcProviderServlet.doGet (Maximo0slcProviderServlet.java:671) [commonweb.jar:?]

- Identify the specific error message indicating a FileNotFoundException for the index.html file in the techmobile directory:
F:\IBM\WebSphere\AppServer\profiles\ctgAppSrv01\MeaGlobalDirs\maximo\maf\techmobile\9.0.0.0-0\index.html

 

Resolving The Problem

To resolve follow these steps:
1. Backup the MAF folder located at (in this example, the disk drive is F:):
F:\IBM\WebSphere\AppServer\profiles\ctgAppSrv01\maximo\maf

2. Delete the entire MAF folder.

3. Attempt to open the Techmobile RBA app again, which should recreate the necessary files in that path.

4. Verify that the 404 error is resolved.

Document Location

Worldwide

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Product Synonym

Maximo Mobile

Document Information

Modified date:
03 April 2026

UID

ibm17268575