Troubleshooting
Problem
Introduction
Microsoft Azure SAML Auth returns error AADSTS7500510
Prerequisites
- Vault versions 1.15.0+ent to 1.15.4+ent
- Vault SAML authentication
- MS Azure Identity Provider
Cause
- The cause of this issue is a bug, where Vault sends a SAML request, which contains an 'IssueInstant' that is not acceptable by Microsoft Azure endpoints.
Solutions:
-
Upgrade to Vault version 1.15.5+ent and above
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSLC9Y2","label":"IBM Vault Self-Managed"},"ARM Category":[{"code":"","label":""}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
Historical Number
26116144839827
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Document Information
Modified date:
16 March 2026
UID
ibm17264609