Troubleshooting
Problem
When attempting to log into vault via the UI, you may observe an infinite hang on the User interface.

While attempting to log into vault via the CLI, you may observe a "context deadline exceeded" error after waiting around 60 seconds.
Example:
$ vault login -method=ldap username=aubry
Password (will be hidden):
Error authenticating: context deadline exceeded
Prerequisites:
- Vault versions v1.14.10 and below
- Vault versions v.1.15.6 and below
Cause
- This issue may be caused by a deadlock when User Lockout feature is enabled.
- To confirm the issue is caused by a deadlock, review the active nodes operational log for the following error:
[ERROR] core: failed to persist failed login user entry: error="context canceled"
- If the error is present, and you are on vault versions v1.14.10. and v.1.15.6 and below, the login failures may be caused by a deadlock on the active Vault node.
Solutions:
- To workaround the issue, restart the vault service on the active node, and disable user lockout.
- To resolve the issue, upgrade vault to v1.14.11 or v.1.15.7 or v1.16.0 and above.
Additional Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSLC9Y2","label":"IBM Vault Self-Managed"},"ARM Category":[{"code":"","label":""}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
Historical Number
35232502540691
Was this topic helpful?
Document Information
Modified date:
16 March 2026
UID
ibm17264431