IBM Support

Error "Template not found" (YFS10379) When Creating Derived Order for Extended Document Type

Troubleshooting


Problem

When creating a Derived Order from a Transfer Order using the createOrder API after configuring an extended Document Type (0008), the system throws following error:
ErrorCode="YFS10379" ErrorDescription="Template not found".

 

Symptom

  • Configure a Document Type 

    Navigate to Application Platform-> Process Modelling -> Orders -> Purchase Order (Save As) -> Document Type(0008)-> Description(MultiHop Order)

    Extended Document Type  MH_FULFILLMENT.ex created

  • Configure a new pipeline under Transfer Order execution -> Save as the already existing pipeline and do the necessary changes to create a Derived Order from a Transfer Order
  • Configure a new transaction under Transfer Order Execution, while configuring select Derive from this abstract transaction (Derived Order Create) -> Add PickUp and Drop status
  • Add a listener => Configure a new transaction => Derived from abstract transaction (derived order status listener) -> Add PickUp and Drop status

 

  • Create an Order with below createOrder API Input, "Template not found" Error  thrown

    CreateOrder API Input-

<Order EnterpriseCode="IBMTO"  ReqDeliveryDate="" SellerOrganizationCode="" DocumentType="MH_FULFILLMENT.ex" OrderType="STERLING" OrderName="" CustomerPONo="" SearchCriteria1="" SearchCriteria2="" PaymentStatus="NOT_APPLICABLE" > 
	<OrderLines>                 
		<OrderLine DeliveryCode="" DeliveryMethod="SHP" ItemGroupCode="" OrderedQty="10" ReqDeliveryDate="" ReqShipDate="" ShipNode="IBM_NY_NODE1">
			<Item ItemDesc="" ItemID="IBMTOItem_1" ProductClass="" UnitCost="1"  UnitOfMeasure="EACH" />
			<DerivedFrom DocumentType="0006" EnterpriseCode="IBM_NY" OrderHeaderKey="2026010806585472670" OrderLineKey="2026010806585472669" OrderNo="Y100000901"/>
			</OrderLine>
		</OrderLines>
		<PersonInfoShipTo  Country="US"></PersonInfoShipTo>
		<PersonInfoBillTo  Country="US" ></PersonInfoBillTo>
	</Order>

 

           CreateOrder API Output-

<Error ErrorCode="YFS10379" ErrorDescription="Template not found" ErrorRelatedMoreInfo="">
	<Attribute Name="ErrorCode" Value="YFS10379"/>
	<Attribute Name="ErrorDescription" Value="Template not found"/>
	<Attribute Name="DocumentType" Value="MH_FULFILLMENT.ex"/>
	<Attribute Name="TemplateType" Value="DerivedOrderDefaultTemplate"/>

 

  • However when create an order without DerivedFrom element, it works fine.

 

 

Cause

 

Diagnosing The Problem

DerivedOrderDefaultTemplate not enabled for extended Document Type and following DB Query returns no result.

SELECT * FROM YFS_BASE_DOCUMENT_TEMPLATE WHERE TEMPLATE_TYPE = 'DerivedOrderDefaultTemplate';

 

 

Resolving The Problem

Enable the "DerivedOrderDefaultTemplate" in the Application Manager like below,

Step 1: Under Process Types swim-lane, right-click on the applicable process type (MultiHop Order execution) and choose Details. 

 

Step 2:  Click on Templated Tab and select Default Derived Order and Save. 

Step 3: Confirm the template is added for DerivedOrderDefaultTemplate

 

SELECT * FROM YFS_BASE_DOCUMENT_TEMPLATE WHERE TEMPLATE_TYPE = 'DerivedOrderDefaultTemplate';

 

Step 4: Create the Derived Order, it should be created without any error.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management System Software"},"ARM Category":[{"code":"a8m0z000000cy00AAA","label":"Orders"}],"ARM Case Number":"TS021109498","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0;9.0.0;9.1.0;9.2.0;9.2.1;9.3.0;9.4.0;9.5.0"}]

Document Information

Modified date:
28 February 2026

UID

ibm17261425