IBM Support

EWM Client Fails to Start After Applying an iFix

Troubleshooting


Problem

After installing an iFix on the Engineering Workflow Management (EWM) client, the application fails to start and report a NullPointerException.

NPE

Cause

The client fails to properly re-provision after installing the iFix, resulting in a NullPointerException.

 

Diagnosing The Problem

Steps to Reproduce:

  1. Download the appropriate ELM iFix.
  2. Extract the update site folder as required.
  3. In the EWM client, open the "Help" menu and select "Install New Software".
  4. Choose the extracted update site folder from the local file system and proceed with installation.
  5. When prompted to restart the client, select "Restart Now".
  6. Upon restart, the client displays a NullPointerException.
  7. Close the error dialog windows and restart the EWM client again. The client may start successfully on the second attempt.

 

 

Resolving The Problem

Steps to Resolve the Problem:

  1. Open the eclipse.ini file located in the EWM or Eclipse installation directory.
  2. Add the following argument on a new line:
    -clean

    Eclipse.ini
     
  3. Save the file and restart the EWM or Eclipse client.

 

Additional Information:

The -clean argument forces the application to re-provision its configuration, which may result in slower startup times during the next launch. After the client successfully starts with the applied iFix, the -clean entry can be removed from the eclipse.ini file.

 

Document Location

Worldwide

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Product Synonym

EWM; Eclipse

Document Information

Modified date:
30 March 2026

UID

ibm17260615