IBM Support

PowerVM (VIOS): VIO_INFO CM Update Mana

Troubleshooting


Problem

On VIOS boot while messages are displayed to the console screen, an error message may occur with the text "pg_dump: error: no matching schemas were found". After boot, the error log would contain an error log entry with title of "VIO_INFO".

ERROR LOG EXAMPLE:

    EA776FCA 0129084526 I S CM Update Mana VIO -- Info

 

Symptom

During boot, messages include PostgreSQL tooling errors (pg_dump / pg_restore) and CM/CMDB artifacts.
VIO_INFO entries appear in the VIOS error log.

EXAMPLE of message displayed on console screen during boot:

    pg_dump: error: no matching schemas were found
    pg_restore: error: directory "/home/vpgadmin/HS" does not appear to be a valid archive ("toc.dat" does not exist)
    a /home/ios/logs/cmdb.fatal.exp/CM_DB/20260129084509/CM
    a /home/ios/logs/cmdb.fatal.exp/CM_DB/20260129084509/CM/3402.dat 1 blocks.
    a /home/ios/logs/cmdb.fatal.exp/CM_DB/20260129084509/CM/3403.dat 3 blocks.  

..

    a /home/ios/logs/cmdb.fatal.exp/CM_DB/20260129084509/HS/tables 0 blocks.
    a /home/ios/logs/cmdb.fatal.exp/CM_DB/20260129084509/HS/toc_extract 0 blocks.

 

 

Cause

This typically occurs when the VIOS Change Management Database (CMDB) cannot resolve the system hostname, preventing population of its internal database.

As a result, internal CM/CMDB initialization fails at boot, which is treated as a fatal condition for the CMDB workflow.

Environment

VIOS ioslevels of 4.1

Diagnosing The Problem

Review the error log and look for VIO_INFO entries by running:

$ errlog | head

ERROR LOG EXAMPLE:

    EA776FCA 0129084526 I S CM Update Mana VIO -- Info      

 

Review the entire error message by running:

$ errlog -ls | more

FULL ERROR LOG ENTRY:

    LABEL: VIO_INFO
    IDENTIFIER: EA776FCA
    Date/Time: Thu Jan 29 08:45:09 CST 2026
    Sequence Number: 56
    Machine Id: 00C447C04B00
    Node Id: XXXXXXX
    Class: S
    Type: INFO
    WPAR: Global
    Resource Name: CM Update Manag
    Description
    VIO -- Info
    Detail Data
    ERNUM
    1000 0008
    ABSTRACT
    Exiting the Change Notification Manager
    AREA
    ChangeManager
    VIO BUILD
    SSP BLD: 25/11/14-11:58:09 h2025_46A2 build@builder733r
    CMD: 1.93
    LOCATION
    viod_cm_fatal_error-viod_chg_notify.c
    DATA
    consecutive errors: 0, status: 0, odm lock count 0
                

    LABEL: VIO_INFO
    IDENTIFIER: EA776FCA

    Date/Time: Thu Jan 29 08:45:09 CST 2026
    Sequence Number: 55
    Machine Id: 00C447C04B00
    Node Id: XXXXXX
    Class: S
    Type: INFO
    WPAR: Global
    Resource Name: CM Update Manag

    Description
    VIO -- Info

    Detail Data
    ERNUM
    1000 0011
    ABSTRACT
    Hostname resolution failed / Bad Hostname
    AREA
    ChangeManager
    VIO BUILD
    SSP BLD: 25/11/14-11:58:09 h2025_46A2 build@builder733r
    CMD: 1.93
    LOCATION
    viod_process_vkebuf-viod_chg_notify.c
    DATA
                

 

Resolving The Problem

The first item to review is how the hostname is resolved. 

If DNS is setup, make sure /etc/resolv.conf file contains the proper name server, and domain search entries if the file exists. 

NOTE: The administrator will need to become root (ie run oem_setup_env) to view this file.

In the /etc/hosts file, verify the contents include the loopback and the VIOS hostname entries. The format of the VIOS hostname should be: IP FQDN alias

EXAMPLE: vios2 has IP (VIOS_IP) and the domain is dfw.ibm.com 

                127.0.0.1               loopback localhost      # loopback (lo0) name/address 

                (VIOS_IP)    (VIOS_Fully_qualified_domain_name)   (VIOS_alias)
                

Note: If you are using IPv4 only, you need to add the IPv4 loopback and remove or comment out the IPv6 loopback.

127.0.0.1 loopback localhost # loopback (lo0) name/address <---- IPv4 loopback
::1 loopback localhost # loopback (lo0) name/address <---- IPv6 loopback

 

During the next boot, the CMDB messages should not occur.

Additional items to review and resolutions can be found in the following document:

When Using HMC GUI you see message "Unable to connect to the Database Error occurred" with scenarios

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8m3p000000PCZsAAO","label":"CMDB"}],"ARM Case Number":"TS021241652","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"4.1.0;4.1.1;4.1.2"}]

Document Information

Modified date:
30 January 2026

UID

ibm17258359