IBM Support

Red Authentication failed for 3 types. message when logging onto Zowe

Troubleshooting


Problem

Notice the following red message when trying to logon to the Zowe desktop:

Authentication failed for 3 types. Types: ["saf","apiml","zss"]

Symptom

We see the following message in the ZWESLSTC joblog when this occurs:

2025-12-10 15:07:13.391 <ZWEAGW1:https-jsse-nio-0.0.0.0-7554-exec-8:83887199> ZWESVUSR WARN (o.z.a.g.s.s.z.AbstractZosmfService) Reo.z.a.g.s.s.z.AbstractZosmfService) Request to z/OSMF requires authentication
2025-12-10 15:07:13.392 <ZWED:1132> ZWESVUSR WARN (_zsf.auth,webauth.js:378) ZWED0003W - User=undefined (org.zowe.zlux.auth.safsso):undefined (org.zowe.zlux.auth.safsso): Session authenticate failed. Plugin response: {"success":false,"reason":"Unknown","error":{"mnknown","error":{"message":"APIML 401 "},"apiml":true,"zss":true,"sso":true,"canChangePassword":true}

Cause

We had forgotten to connect the user to the following profiles:

CONNECT (damo) GROUP(IZUADMIN) AUTH(USE)
CONNECT (damo) GROUP(IZUUSER) AUTH(USE)
CONNECT (damo) GROUP(ZWEADMIN) AUTH(USE)

 

This is part of the ZWESECUR JCL that was run when Zowe was installed.

Diagnosing The Problem

We figured this out by comparing the RACF profile of a user ID that was able to logon to Zowe, with the new user ID that was not able to. 

Resolving The Problem

After doing the connects followed by a RACF refresh, the user was able to logon to Zowe successfully.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB70","label":"Z TPS"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSVHRS","label":"IBM Z Distribution for Zowe"},"ARM Category":[{"code":"a8mgJ0000000841QAA","label":"Zowe"}],"ARM Case Number":"","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.0.0;1.9.0;2.0.0;3.0.0"}]

Document Information

Modified date:
02 March 2026

UID

ibm17254365