Troubleshooting
Problem
IBM Storage Protect for Virtual Environments vCenter Plugin Issue: "Getting Started" Page vCenter Field Is Empty
Symptom
When reviewing the VE GUI messages.log file located at:
C:\IBM\SpectrumProtect\webserver\usr\servers\veProfile\logs
you will notice repeated error entries accompanied by a Java exception message. For example "java.lang.NullPointerException"
[Timestamp 16:51:30:648 CET] 0000002e SystemOut O Error connecting vCenter Server. Unable to authenticate.
[Timestamp 16:51:30:648 CET] 0000003e SystemOut O idxName: C:\IBM\SpectrumProtect\webserver\usr\servers\veProfile\tsmVmGUI\TSM.IDX
[Timestamp 16:51:30:648 CET] 0000002e SystemErr R Not authorized connection, handleRequest()
[Timestamp 16:51:30:648 CET] 0000003e SystemOut O file not found
Cause
The password files required for the truststore might be missed or corrupted from the following directory:
C:\IBM\SpectrumProtect\webserver\usr\servers\veProfile\tsmVmGUI
Without these files, the vCenter plugin cannot access the truststore, which results in initialization errors and prevents the "Getting Started" page from displaying the vCenter field correctly.
Environment
IBM Storage Protect for Virtual Environments: Data Protection for VMware version 8.1 on all supported Windows platforms
Resolving The Problem
Follow these below steps to recreate the password file.
1.Log out of vCenter Web Client
Close the browser window completely to ensure no active sessions remain.
2.Move the truststore file
Navigate to: C:\IBM\SpectrumProtect\webserver\usr\servers\veProfile\tsmVmGUI\truststores\
Move the file tsm-ve-truststore-restservice.jks to a different location.
3.Move additional files (if present), In the tsmVmGUI directory, check for the following files:
TSM.KDB
TSM.IDX
TSM.STH
4.Log back in to vCenter
Reopen the vCenter Web Client.
Retry the plugin, so that the system will recreate the missing password/truststore files automatically.
Related Information
Document Location
Worldwide
Historical Number
TS015931103
Product Synonym
TSM4VE;TDPVE;VMware
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Document Information
Modified date:
03 March 2026
UID
ibm17251111