Troubleshooting
Problem
AWS S3 resource buckets with S3 Object Lock enabled fail with HTTP 400 Bad Request.
Cause
IBM Cloud Storage Solutions for i (ICC) currently does not support Amazon S3 Object Lock-enabled buckets. This is because the ICC CPYTOCLD command currently does not set the Content-MD5, x-amz-sdk-checksum-algorithm, or x-amz-checksum-sha256 HTTP header on the HTTP request.
"The Content-MD5 or x-amz-sdk-checksum-algorithm header is required for any request to upload an object with a retention period configured using Object Lock. Theses headers are a way to verify the integrity of your object during upload."1
[1] “Object Lock Considerations - Amazon Simple Storage Service.” Object Lock Considerations, Amazon Web Services, Inc. or its affiliates, docs.aws.amazon.com/AmazonS3/latest/userguide/object-lock-managing.html. Accessed 11 Nov. 2025.
Environment
IBM i
IBM Cloud Storage Solutions for i (5733-ICC)
Amazon Web Services (AWS) S3 (Simple Storage Service)
Diagnosing The Problem
IBM Cloud Storage Solutions for i flight recorder will show a HTTP 400 Bad Request response along with an InvalidRequest message from Amazon detailing how the Context-MD5 or x-amz-checksum request header was not set, which is required with Amazon S3 Object Lock.
2025-11-10 09:37:58 buildS3Request: Canonical Request = PUT
2025-11-10 09:37:58 00000000 |400 Bad Request..x-amz-request-i|
2025-11-10 09:37:58 00000020 |d: 2JFXGTDR6A54MS0P..x-amz-id-2:|
2025-11-10 09:37:58 00000040 | U/8UDC3q/xAOxfPzZWIlB82tcrf3+g3|
2025-11-10 09:37:58 00000060 |ARQIS3TVIp+EnqyuNenZFl0aXcw0n0Dh|
2025-11-10 09:37:58 00000000 |<Error><Code>InvalidRequest</Cod|
2025-11-10 09:37:58 00000020 |e><Message>Content-MD5 OR x-amz-|
2025-11-10 09:37:58 00000040 |checksum- HTTP header is require|
2025-11-10 09:37:58 00000060 |d for Put Part requests with Obj|
2025-11-10 09:37:58 00000080 |ect Lock parameters</Message><Re|
2025-11-10 09:37:58 000000A0 |questId>2JFXGTDR6A54MS0P</Reques|
2025-11-10 09:37:58 000000C0 |tId><HostId>U/8UDC3q/xAOxfPzZWIl|
2025-11-10 09:37:58 000000E0 |B82tcrf3+g3ARQIS3TVIp+EnqyuNenZF|
2025-11-10 09:37:58 00000100 |l0aXcw0n0DhH9OxE2VIDiEIXAFJT6BdJ|
2025-11-10 09:37:58 00000120 |C8zgTrJlFFkm</HostId></Error>|
Resolving The Problem
Recreate the Amazon S3 bucket to disable Object Lock on the bucket. Then, resubmit your ICC command.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
11 November 2025
UID
ibm17250867