IBM Support

When translating inbound EDI data, Compost hangs and after stopping/starting Gentran Services and Resetting In Process files, Red papers appears in the ?OUT drawer

Troubleshooting


Problem

While processing an inbound EDI data file manually, using Commands/Process file Compost hangs.
There are Red Papers in the OUT? 
The GENTRAN Services must be manually stopped and restarted to end the process. See this link
Also, the Documents need to be Reset.  View/Processing/highlight the documents and then click Reset.

Symptom

In the auditlog it indicates 3-1-1729 Translator:Relationship not found
Translator: Primary key: PARTNER, PartnerName, DIRECTION: Out, AGENCY: X, VERSION: 004010
Translator:######; TRANSACTION SET: 999, RELEASE: 0, TEST MODE: T
Translator: Header: BYTE OFFSET: 846, HEX
Import Session Started C:\GENSRVNT\Temp\AKG7C38.tmp
Immediate acknowledgment generation is starting for InterchangeKey 186 

Cause

The Inbound Partner Relationship/Inbound Group entry (for the inbound received), under the Group Advanced button, had for the Ack Transaction Set ID had 999 selected in the drop-down.  There was not an Outbound Relationship for a 999 set up in the partner, as the 997 should have been selected in the Inbound/Group relationship.
InboundGroupAdvanced

Diagnosing The Problem

In checking the Auditlog it is unable to find a Relationship for the 999, because the Functional Ack set up in the Partner Outbound Relationship is for a 997
 

Resolving The Problem

Change the Inbound Group Advanced button for the Ack Transaction Set ID to 997
InboundGroupAdvanced
And the 
Outbound997_Translation_button

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6V3G","label":"Sterling Gentran:Server for Microsoft Windows"},"ARM Category":[{"code":"a8m50000000KzZRAA0","label":"Mapping and Translation"},{"code":"a8m50000000L08gAAC","label":"Sterling Gentran:Server for Microsoft Windows-\u003EGeneral-\u003EPartners-\u003ESetup"}],"ARM Case Number":"TS020686293","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"5.1.0;5.2.0;5.3.0;5.3.1"}]

Document Information

Modified date:
23 January 2026

UID

ibm17250731