IBM Support

Fibre Channel Multipath Automatic Path Disablement

Troubleshooting


Problem

In IBM i 7.6 Technology Refresh 1, IBM i 7.5 Technology Refresh 7 (Nov 2025) new functionality has been added to automatically disable the path when error thresholds are exceeded.   This was announced in the Tech Refresh Memo-To-Users. 

  • https://www.ibm.com/support/pages/ibm-i-functional-enhancements-details
  • Automatic detection and disablement of disk paths over the threshold is not activated by default. Use the following SQL command to Allow the hardware to automatically detect and disable performance-reducing I/O paths:
    CALL QSYS2.CHANGE_DISK_PATHS(OPERATION => 'ACTIVATE PATH MANAGEMENT'

 

Symptom

When error thresholds are exceeded the path will be disabled and a Product Activity Log entry will be generated with the following format - XXXX3002

The PAL entry will have the following text "SLIC DASD DEVICE DRIVER ERROR: ERROR THRESHOLD EXCEEDED. PATH DISABLED.”

Cause

The following device driver errors will be tracked and the path disabled when the thresholds are exceeded:
 

  • - TransportError
  • - HostIoBusError
  • - AdapterHdwFailure
  • - AdapterSfwFailure
  • - NoDeviceResponse
  • - CmdTimeout
  • - TransportHardFault
  • - TransportReset
  • - TransportBusy
  • - TransportDead

Environment

IBM i 7.6 Technology Refresh 1, IBM i 7.5 Technology Refresh 7 

Diagnosing The Problem

Disk performance problems are often encountered when path errors occur.  This change has been made to help identify and mitigate the performance impact while the path is investigated and the hardware problem is addressed.  

The path will be disabled and a Product Activity Log (PAL) entry will be generated when error thresholds are exceeded.   

The entry will have the following SRC code:
XXXX3002 - where XXXX is the 4 digit type of the adapter
The PAL entry will have the following text "SLIC DASD DEVICE DRIVER ERROR: ERROR THRESHOLD EXCEEDED. PATH DISABLED.”

 

The path will remain disabled until the system is IPL'd OR the problem is corrected and the path manually restored.  Automatic recovery only occurs if ALL paths for a given LUN have failed.   If that occurs, this functionality is disabled for that LUN until the system is IPL'd.  

To manually recover after addressing the hardware problems the following procedure can be used - CHANGE_DISK_PATHS - which is documented at the following link. 

Also see document: "Repeating SRCB6008000 or SRCB6008001 (CPPEA33) and SRCB6008003 (CPPEA35) can cause performance issues"

 

Document Location

Worldwide

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Document Information

Modified date:
15 January 2026

UID

ibm17250312