IBM Support

Sterling B2B Integrator on Windows: After an successfull installation the noapp service fails to startup correctly

Troubleshooting


Problem

The Sterling B2B Integrator Windows services are trying to start, but the Noapp Service fails to come up entirely and appears to be hanging.

Symptom

Cause

There is the Sentinel One anti malware running on the Windows Server which is preventing the B2Bi Noapp.exe service to complete it's startup phases.

Environment

Microsoft Windows Server
Sterling B2B Integrator (any version)
The Sentinel One anti malware is running on the server and scanning the Sterling B2B Integrator directories.

Diagnosing The Problem

Request the customer to export the events from the Windows Event Viewer under Applications and System to a *.wer file format.
The files are generated automatically when an application crashes or becomes unresponsive.
The files can be stored in: %LOCALAPPDATA%\Microsoft\Windows\WER\ReportArchive or %ProgramData%\Microsoft\Windows\WER
At the moment when the noapp.exe crashes verify the presence of the SentinelOne dll: 

UI[2]=D:\IBM\SI\bin\Noapp.exe
UI[5]=Close
UI[8]=Commons Daemon Service Runner stopped working and was closed
UI[9]=A problem caused the application to stop working correctly. Windows will notify you if a solution is available.
UI[10]=&Close
LoadedModule[0]=D:\IBM\SI\bin\Noapp.exe
LoadedModule[1]=C:\Windows\SYSTEM32\ntd1l.dll
LoadedModule[2]=C:\Windows\System32\kern3l32.dll
LoadedModule[3]=C:\Windows\SYSTEM32\ntdll.dll
LoadedModule[4]=C:\Windows\System32\KERNEL32.DLL
LoadedModule[5]=C:\Windows\System32\KERNELBASE.dll
LoadedModule[6]=C:\Program Files\SentinelOne\Sentinel Agent 24.1.5.277\InProcessClient64.dll
LoadedModule[7]=C:\Windows\System32\ADVAPI32.dll

Resolving The Problem

Contact the security team to verify the configuration of Sentinel One and ensure the Sterling B2B Integrator application has been added to the exclusion list.

Document Location

Worldwide

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Document Information

Modified date:
09 October 2025

UID

ibm17247443