IBM Support

Error: "This policy is not available on selected gateway" displayed in API Manager UI

Question & Answer


Question

When editing an API in the Manager UI > Develop tab and navigating to the Gateway tab under Policies, the following error message is displayed:
    "This policy is not available on selected gateway."
error
 

Cause

 This error occurs when the Sandbox catalog does not have a gateway(s) service(s) associated with it.

Answer

Add a Gateway Service for both or either following gateway types to the Sandbox catalog: 
  • datapower-gateway for the DataPower Gateway (v5 compatible)
  • datapower-api-gateway for the DataPower API Gateway.
This will enable the policy or policies to be available for selection and use. You need to add the gateway type depending on which policy you plan to use.
The steps to resolve this issue:
  1. In API Manager UI > Go to Manage
  2. Click Sandbox catalog
  3. Go to Catalog settings > Gateway services
  4. Click Edit button and add the gateway(s)
     

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Document Information

Modified date:
18 September 2025

UID

ibm17245408