Question & Answer
Question
When editing an API in the Manager UI > Develop tab and navigating to the Gateway tab under Policies, the following error message is displayed:
"This policy is not available on selected gateway."

Cause
This error occurs when the Sandbox catalog does not have a gateway(s) service(s) associated with it.
Answer
Add a Gateway Service for both or either following gateway types to the Sandbox catalog:
- datapower-gateway for the DataPower Gateway (v5 compatible)
- datapower-api-gateway for the DataPower API Gateway.
This will enable the policy or policies to be available for selection and use. You need to add the gateway type depending on which policy you plan to use.
The steps to resolve this issue:
- In API Manager UI > Go to Manage
- Click Sandbox catalog
- Go to Catalog settings > Gateway services
- Click Edit button and add the gateway(s)
[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSMNED","label":"IBM API Connect"},"ARM Category":[{"code":"a8mKe000000CaZVIA0","label":"API Connect-\u003EAPIC Gateway"}],"ARM Case Number":"TS020161728","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"and future releases;10.0.5"}]
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Document Information
Modified date:
18 September 2025
UID
ibm17245408