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Export option does not complete the download process in MAS 9.1

Troubleshooting


Problem

In Maximo Application Suite 9.1, you can export or download users data to an external file system for backup or importing to another Maximo Application Suite instance. But, in some cases, the download does not complete and the csv file is not generated.

Symptom

The export file cannot be generated with users data.

Cause

This behavior occurs as each export request requires a synchronization process that needs to be concluded until the next request starts to process.

Diagnosing The Problem

In Maximo Application Suite 9.1, on the side navigation menu, select Suite > Security > Users and then click the download icon.
Then, in Export data, export either visible columns or custom columns data. The download does not complete.

Resolving The Problem

This is a known issue under defect DT448834, already fixed in Manage Base - Patch 9.1.3.
 
As a workaround, follow the instructions below:
 
1. Login into Maximo Application Suite 9.1;
 
2. Go to Suite > Security > Users:
 
image-20250819151230-1
 
3. Filter the user or users you want to export:
 
image-20250819151548-2
 
4. Click Export option:
 
image-20250819151644-3
 
5. Select Export custom columns and clear Template name. Do not click export yet:
 
image-20250819151847-5
 
6. Open Dev Tools on your browser (Press F12), go to Network tab and Clear Network log:
 
image-20250819152016-6
 
7. Click Export in Maximo:
 
image-20250819152129-7
 
8. A masperuser request url shows in Network logs:
 
image-20250819152224-8
 
9. Copy the URL:
 
image-20250819152250-9
 
10. Paste it in a notepad and remove async=1& parameter:
 
image-20250819152540-10
 
11. Copy the url without async:
 
image-20250819152648-11
 
11. Paste it in a browser tab, hit enter and the csv file is generated:
 
image-20250819153011-12
 
 
 

Document Location

Worldwide

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Document Information

Modified date:
29 October 2025

UID

ibm17242572