IBM Support

Platform update task shows Completed on Tasks Log but GUI task still shows Applying updates

Troubleshooting


Problem

The Platform Update operation (Update system, VIOS, adapter levels) task shows in the Task log with a status of Completed, but the progress bar on the task's graphical user interface page may still show it is Applying updates.
The Platform Update operation applies to Power11 systems, when managed by a v11r1.1110 HMC.

Symptom

In the Platform Update operation, the user can select to update the System Firmware, VIOS, and I/O adapter levels, combined. 
In rare cases the task panel can show that one of the sections is still Applying updates... but the Tasks Log of the HMC, shows that the operation has already Completed.
platform update issue

Cause

The problem is in the graphical user interface (GUI), and not the logic behind the platform update. 

Diagnosing The Problem

Steps to view the Tasks Log on the HMC and verify completion of the task.
  1. If the left menu is not already open, click on the menu button on the top left corner of the HMC user interface
     image-20250718102905-1
  2. From the left menu, click Logs
  3. Click Tasks Log
  4. Locate the task that corresponds to the platform update. The task name shows Platform update for system <MTMS>. 
  5. Verify the status column shows Completed 

Resolving The Problem

If the Tasks Log shows the status as Completed, the task panel showing the progress of the overall operation, can be closed, and the section showing Applying updates... can be ignored. 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"7063CR2","label":"Hardware Management Console (7063-CR2)"},"ARM Category":[{"code":"a8m0z000000GnS5AAK","label":"HMC"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}]},{"Type":"MASTER","Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSJKZ48","label":"Hardware Management Console V11"},"ARM Category":[{"code":"a8m0z000000bowEAAQ","label":"Hardware Management Console"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":""}]

Document Information

Modified date:
28 July 2025

UID

ibm17240073