Troubleshooting
Problem
Error while exporting PBI report data (Data Limit Exceeded)
Power BI report, whenever we try to export this data with the settings “Data with current layout”, And when we click on export we are getting an error: “Executing the query for the export data operation resulted in an error”

But When we click on “summarize data”, It will export normally. But it does not export when you click on “Data with current layout”.
However, Summarize data does not provide the output we need.

We get the Error “Data Limit exceeded”.

Although the data limit is not exceeded. We understand that the limit is 150,000 rows for XLSX and 30,000 for CSV. Report fails at about 20000 rows as per the below KB
Data Export Limitations – Power BI has export limits depending on the file format:
- Excel (.xlsx): Up to 150,000 rows.
- CSV: Up to 30,000 rows.
We lowered the number of rows, it worked. But when we increase the number of rows (sill below the limit) it fails. We tried both XLSX and CSV. Still fails.
Power BI Desktop is UpToDate.

Symptom
Cause
Your Capacity Admin has configured 'Max Result Row Count' setting to be 21474 the row returned for Excel export is greater than this number, causing the export to fail, you need to increase the Row Count in Capacity Setting.
Environment
Microsoft Power BI Desktop Version: 2.143.878.0 64-bit (May 2025)
Diagnosing The Problem
After We checked the Capacity admin, we see the following:
Your Capacity Admin has configured 'Max Result Row Count' setting to be 21474 the row returned for Excel export is greater than this number, causing the export to fail, you need to increase the Row Count in Capacity Setting.
Resolving The Problem
After We checked the Capacity admin, we see the following:
Your Capacity Admin has configured 'Max Result Row Count' setting to be 21474 the row returned for Excel export is greater than this number, causing the export to fail, you need to increase the Row Count in Capacity Setting.
How to configure workloads in Power BI Premium - Power BI | Microsoft Learn
To resolve this issue, you will need to increase the Row Count in the Capacity Setting. Here is a brief guide on how to do that:
1. Navigate to the admin portal.
2. Go to Capacity settings.
3. Select the capacity assigned to the workspace in question.
4. Access Power BI Workloads.
5. Adjust the Max Result Row Count setting to a higher value.
Please ensure that your Capacity Admin makes these adjustments to increase the row count.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
17 July 2025
UID
ibm17239948