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Troubleshooting "java.net.SocketException: Permission denied: connect" errors are found in Cognos Analytics systems on Windows

Troubleshooting


Problem

Security software is blocking connections when attempted by Cognos Analytics.

Symptom

Various tasks fail in Cognos Analytics, such as scheduled reports, data source queries, loading administration pages, etc.

Cause

Security software, such as Windows Firewall, or 3rd party Endpoint Detection and Response (EDR) solutions are blocking connections due to restrictive policies.

Diagnosing The Problem

Log files like cogaudit.log and cognosserver.log in <install_directory>\logs show various operations fail with error "java.net.SocketException: Permission denied: connect", for example:
CNC-GEN-2107 An unexpected error has occurred. The message is: RequestOperation = null  ERROR : ; nested exception is:  	com.cognos.jsmcommon.api.APIException: CNC-MON-0024 Monitor Service paging error: java.net.SocketException: Permission denied: connect 
Server admins can find logs in Windows Event Viewer that might confirm when security software is blocking connections. A good place to start is opening:
Event Viewer (Local) > Windows Logs > Security
Under the "Actions" menu go to "Filter Current Log..." and click the "Keywords" dropdown menu. Check the box for "Audit Failure" and press "OK".
filt
You can then correlate the date and time of the errors that are found in Cognos Analytics with the Audit Failure logs in Event Viewer. Determine whether any security policies or devices that block connections. Look for the following event-type:
Event ID 5157 – The Windows Filtering Platform has blocked a connection

Resolving The Problem

If connection blockages are found, review and adjust security device policies for Windows to allow Cognos Analytics to make connections to external endpoints required to for it to operate properly.

Document Location

Worldwide

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Document Information

Modified date:
31 July 2025

UID

ibm17239512