IBM Support

Why did “updateios” report as failed even if all the filesets were successfully applied.

Question & Answer


Question

This document describe why, in some circumstances, the “updateios” command exits with “rc=1” or HMC shows failed status during update from GUI. Nevertheless, all filesets looks correctly applied, and the ioslevel command reports the expected level.

Cause

In many case when updateios command is issue from command line, if you check the return code from updateios command you may see it is 1. (In UNIX environment, a non-zero return code usually indicates an error)
If you performed the VIOS update from HMC GUI, you may see the following result :

image-20250606100114-1

Answer

In that case, you need to have a closer look at details of the update process. To do so, either go through the output given in HMC GUI, or go through the “install.log” file located under “/home/padmin” (if updateios run from VIOS CLI) or “/” (if update performed from HMC) on the VIOS.
There are a couple of error that could be safely ignored. 
Indeed the VIOS image now has a long history, and depending on the original level it was installed and all the different versions applied, some fileset from the update package might not be applicable.
The key point is to review the summary of all applied fileset and make sure they all report as “APPLY” / “SUCCESS”. If one reports failed, cleaned and so on, this might indicate an issue.

Here are few examples of “false” error reported :
1. mls and svprint language filesets
There are some message packages for certain languages which does not exist on the current VIOS installation. The update are still in the update package as for some installations those fileset are still installed, otherwise you may see :

bos.msg.pt_BR.svprint 7.2.5.0 Requisite failure
bos.msg.pt_BR.mls.rte 7.2.5.0 Requisite failure
bos.msg.it_IT.svprint 7.2.5.0 Requisite failure

bos.msg.it_IT.mls.rte 7.2.5.0 Requisite failure
bos.msg.fr_FR.svprint 7.2.5.0 Requisite failure
bos.msg.fr_FR.mls.rte 7.2.5.0 Requisite failure
bos.msg.es_ES.svprint 7.2.5.0 Requisite failure

bos.msg.es_ES.mls.rte 7.2.5.0 Requisite failure
bos.msg.en_US.mls.rte 7.2.5.0 Requisite failure
bos.msg.de_DE.svprint 7.2.5.0 Requisite failure
bos.msg.de_DE.mls.rte 7.2.5.0 Requisite failure
bos.msg.ca_ES.svprint 7.2.5.0 Requisite failure
bos.msg.ca_ES.mls.rte 7.2.5.0 Requisite failure

The error above occurs because the mls fileset and the svprint fileset are not installed on that VIOS, which is actually not an issue and might be safely ignored.
This is described in the update package release notes (for instance in 4.1.1.0)

2. LDAP filesets update
VIOS is now using LDAP version 10.0 and thus update error from previous versions 6.4 can be safely ignored. If you are seeing the following error :

idsldap.license64.rte       6.4.0.25        USR         APPLY       FAILED
idsldap.license64.rte       6.4.0.25        USR         CLEANUP     SUCCESS
idsldap.cltbase64.rte       6.4.0.25        USR         APPLY       CANCELED
idsldap.cltbase64.adt       6.4.0.25        USR         APPLY       CANCELED
idsldap.clt64bit64.rte      6.4.0.25        USR         APPLY       CANCELED
idsldap.clt32bit64.rte      6.4.0.25        USR         APPLY       CANCELED

This is also described in update package release notes (for instance in 3.1.4.50)

As a general rule, if you are seeing return code 1 or failed reported by HMC during an updateios, first of all check the output of the updateios to find out what is the reason of the return code = 1. Once found you may want to check the release for the version you are applying and or this technote.

Should you have any doubt about your findings, or if the error you are seeing is not listed in the release note, please contact IBM PowerVM support.

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8m50000000L0OUAA0","label":"UPDATE-\u003Eupdateios_problems"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.1.0;1.2.0;1.3.0;1.4.0;1.5.0;3.1.0;3.1.1;3.1.2;3.1.3;3.1.4;4.1.0;4.1.1"}]

Document Information

Modified date:
06 June 2025

UID

ibm17235806