IBM Support

ZLDA Splunk Cloud Application Upload Fails After April 29, 2025

Troubleshooting


Problem

Customers attempting to upload the ZLDA Splunk Cloud application (ibm_zlda_insights_cloud.spl) to Splunk Cloud may encounter a failure during the upload process. The application fails validation and cannot be installed.

Cause

On April 29, 2025, Splunk released AppInspect v3.10.0, which introduced a new validation check: check_reload_trigger_for_meta.
This check requires that any stanza in the metadata directory referencing a custom configuration file must have a corresponding reload trigger defined in the app’s app.conf file. Versions of the ZLDA application prior to Fix Pack 21 do not include this trigger, resulting in a validation warning that blocks installation.

Environment

ZLDA Splunk Cloud App :   All versions prior to 5.1.x.21 (Fix Pack 21)
Splunk AppInspect :   v3.10.0 and later
Platform:    Splunk Cloud

Diagnosing The Problem

When running AppInspect v3.10.0 or later, the following warning is generated:

{
  "name": "check_reload_trigger_for_meta",
  "result": "warning",
  "messages": [
    {
      "message": "Stanza [lookups] requires a conf-level reload trigger. Add reload.lookups to [triggers] stanza in app.conf. File: default/app.conf"
    }
  ]
}


This warning causes the Splunk Cloud platform to reject the application upload, as warnings are treated as blocking issues for cloud deployments.
 

Resolving The Problem

This issue is resolved in ZLDA Fix Pack 21.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB70","label":"Z TPS"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSFCOSY","label":"IBM Z Operational Log and Data Analytics"},"ARM Category":[{"code":"a8m3p000000hBM3AAM","label":"ZLDA-\u003EPLANNING AND INSTALLATION"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":""}]

Document Information

Modified date:
20 May 2025

UID

ibm17233977