IBM Support

QRadar EDR オンプレミス: アラートの通知機能が動作しない事象について

Troubleshooting


Problem

突然、アラートの通知機能が動作しない場合があります。

Symptom

トリガーされたアラートが E メールやダッシュボード上、あるいはその両方で通知されなくなる場合があります。

Cause

まずは、以下をチェックいただき、全て問題がない場合は、RabbitMQ 接続の問題が原因である可能性があります。
  • ダッシュボード上の Notification Settings (画面右上のベル・マーク) 内の「 Alerts 」セクションで「 Email 」や「 In-App 」、もしくはその両方にチェックが入っている。(有効になっている。)
  • Notification Settings 内の「 SMTP Configuration 」が正しく設定されている。
  • 関連するメールサーバーの設定、および環境に変更がない。

Environment

QRadar EDR オンプレミス

Diagnosing The Problem

RabbitMQ 接続の問題である場合、Mustgather のログに以下のようなメッセージが表示されます。
[warning] <0.690624.0> client unexpectedly closed TCP connection
(...)
<0.692444.0> Channel error on connection <0.692385.0>
(...)
operation exchange.bind caused a channel exception not_found: no exchange 'maiaNewIncidents
これは RabbitMQ への接続が閉じられ、その後 maia (フロントエンド・コンポーネント)が新しいアラートに関するメッセージ (AKA通知) を受信するために、新しいキューを使用して Exchange に接続しようとしたが、失敗したことを示唆しています。
 

Resolving The Problem

この問題を解決するには、oc でクラスタにログインし、次のコマンドを実行して maia を再起動してください。
oc rollout restart deployment/reaqta-hive-maia --namespace $NAMESPACE

Document Location

Worldwide


本文書は、米国 IBM 社の資料を翻訳した参考文書です。翻訳元の文書は、Related Information の翻訳元 (英語) リンクよりご参照ください。
 

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSS3Y22","label":"IBM Security QRadar Suite - EDR"},"ARM Category":[{"code":"a8m3p000000hBSAAA2","label":"Administrative Tasks"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Product Synonym

ReaQta

Document Information

Modified date:
28 May 2025

UID

ibm17233937