IBM Support

Supported Encoding Format for PCOMM Configuration Files

Troubleshooting


Problem

IBM Personal Communications session files (.WS) and configuration files are designed to read and write only in ANSI and UTF-8 formats.

Symptom

All files generated by PCOMM are saved either in ANSI or UTF-8 encoding. Files saved in other formats (such as UTF-16 LE with BOM, UTF-16 BE, etc.) are not compatible with PCOMM and may fail to load correctly.

Cause

  • PCOMM version 15 and later support only UTF-8 and ANSI encoded configuration files. Support for alternative encodings, such as UTF-16 LE with BOM, which may have functioned in earlier versions, can result in unexpected behavior with the configuration file.
  • Files encoded in unsupported formats may fail to load or unexpected behavior in PCOMM. 
 
Workaround
 
Execute the following steps to resolve the issue with unsupported file encoding:
  1. Open the .WS or .INI file using a text editor.
  2. Convert the file encoding to UTF-8 or ANSI.
  3. Save the file.
  4. Relaunch PCOMM and retry loading the session.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB70","label":"Z TPS"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSEQ5Y","label":"Personal Communications"},"ARM Category":[{"code":"a8m0z0000000CBWAA2","label":"PCOMM"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"15.0.0"}]

Document Information

Modified date:
13 May 2025

UID

ibm17233233