IBM Support

QRadar : X-Force API subscription changes

Troubleshooting


Problem

Changes made to IBM X-Force subscriptions might affect QRadar and Threat Intelligence (TI) feed.

Cause

Previously free API keys with restricted access to the X-Force APIs could be be used. IBM X-Force have recently changed their subscriptions removing access to their API for Freemium API keys.

For more details you can refer the following links:
 

X-Force Threat Intelligence Offerings:

subs

 

 

Diagnosing The Problem

You can test your API key and it's corresponding access using following command:
curl -u <API KEY>:<API PASSWORD>  https://api.xforce.ibmcloud.com/url/
Your API key does not have access to the X-Force API if this error is returned.
{"error":"You currently have a Freemium tier subscription with limited access to the X-Force Exchange portal. For API access and to learn more about our premium subscriptions, please visit our <a href='https://www.ibm.com/products/xforce-exchange/editions' target='_blank'>digital marketing page</a> where you can sign up for a 30-day Standard tier trial."}
If your API key has access to the X-Force API you will receive a response with information on the URL you searched for.

Resolving The Problem

Purchase a subscription that allows access to the IBM X-Force API.
If you need more details get in touch with IBM X-Force directly using the email of xfe@us.ibm.com .

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSUVUN","label":"IBM Security QRadar SIEM All-in-One 21XX"},"ARM Category":[{"code":"a8m0z000000cwt3AAA","label":"QRadar Apps"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1.0;7.2.0;7.2.2;7.2.3;7.2.4;7.2.5;7.2.6;7.2.7;7.2.8;7.3.0;7.3.1;7.3.2;7.3.3;7.4.0;7.5.0"}]

Document Information

Modified date:
22 December 2025

UID

ibm17233123