IBM Support

E1080 (9080-HEX) upgrade to FW1060 fails with HSCF0180E

Troubleshooting


Problem

When upgrading the E1080 (9080-HEX) to FW1060 from an earlier release and the disruptive license internal code upgrade is started from the Operating or Standby state the upgrade will result in returning the following failure:
HSCF0180E Operation failed for <system_name>. Licensed Internal code was changed as requested, but a failure occurred returning the managed system to its original state. If the managed system is connected, try the operation again. If not, or the operation fails after retry, contact support.
The process times out with no real indication to the user that the power on of the system is taking longer than the timeout allowed during the firmware upgrade task.

Symptom

The Permanent side will be left on the previous firmware level, ie (FW1050, FW1030 etc.).

Cause

Root cause:
An SBE update is contained in this FW1060.10 service pack that will make the firmware update take longer.

SBE Updates Power10 servers contain SBEs (Self Boot Engines) and are used to boot the system. SBE is internal to each of the Power10 chips and used to "self boot" the chip. The SBE image is persistent and is only reloaded if there is a system firmware update that contains a SBE change. If there is a SBE change and system firmware update is concurrent, then the SBE update is delayed to the next IPL of the CEC which will cause an additional 3-5 minutes per processor chip in the system to be added on to the IPL. If there is a SBE change and the system firmware update is disruptive, then SBE update will cause an additional 3-5 minutes per processor chip in the system to be added on to the IPL. During the SBE update process, the HMC or op-panel will display service processor code C1C3C213 for each of the SBEs being updated. This is a normal progress code and system boot should be not be terminated by the user. Additional time estimate can be between 12-20 minutes per drawer or up to 48-80 minutes for maximum configuration.
The time can exceed 90 minutes leading to the firmware upgrade timeout to return the system to its original state (Standby or Operating) during the code upgrade.

Environment

9080-HEX upgrades to FW1060 when not in Power Off state at the beginning of the firmware upgrade.

Diagnosing The Problem

Anytime HSCF0180E is received during a firmware upgrade to FW1060 on a 9080-HEX

Resolving The Problem

Accept the firmware to the Permanent side, select the managed system, navigate to "Firmware" -> "Backup system firmware"
Backing up system firmware will copy the current firmware level to the permanent side flash storage of the system. Once the firmware level is backed up, it cannot be reverted. System firmware can be backed up for FSP based systems only.
From CLI: updlic -o c -m -t sys -v
The above is a concurrent action and does not require an outage

In order to avoid this issue on other 9080-HEX upgrades, first Power off the server before beginning the disruptive firmware upgrade.

Document Location

Worldwide

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Document Information

Modified date:
12 May 2025

UID

ibm17233012