IBM Support

Unable to Create a PDF After Upgrade to V7R5 or V7R6

Troubleshooting


Problem

After an upgrade to V7R5 or V7R6, PDFs are not being created using the Copy Spooled File (CPYSPLF), Override Printer File (OVRPRTF), through Access Client Solutions (ACS) or Navigator for i.  No errors are seen.

Symptom

Unable to create PDFs using Transform Services at V7R5 or V7R6.

Cause

QUSRWRK subsystem is not active

Environment

IBM i OS V7R5 or V7R6

Diagnosing The Problem

After an upgrade, PDFs are not being created using any method and no errors are logged.  
The ACTIVE TASKS pane in ACS Printer Output shows the spooled file attempting to download but does not progress past 5%.  
The CPYSPLF or OVRPRTF commands from the command line or program do not complete.

Resolving The Problem

Ensure QUSRWRK subsystem is started:  STRSBS SBSD(QUSRWRK)
Check and change the IPL start up program to ensure QUSRWRK subsystems is started after an IPL.
The Memo to Users documents the changes to the product at V7R5.
Transform Services runs in QUSRWRK:  https://www.ibm.com/docs/en/i/7.5.0?topic=programs-transform-services-5770-ts1
From this information under General tips for successful use of Transform Services:
Ensure QUSRWRK subsystem is started after an IPL and the maximum jobs in subsystem (MAXJOBS) is set to a higher value or *NOMAX: CHGSBSD SBSD(QUSRWRK) MAXJOBS(*NOMAX)

Please review the MTU for more information about other changes for the product at VR75.

Document Location

Worldwide

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Document Information

Modified date:
14 April 2025

UID

ibm17230906