IBM Support

Error IDENTIFIER B0EE9AF5 or IDENTIFIER 65DE6DE3 logged on AIX or VIO server

Question & Answer


Question

AIX server is reporting recurring errors with identifier B0EE9AF5 associated with MPIO hdisk devices. What is the root cause?
 
errpt |more

IDENTIFIER TIMESTAMP T C RESOURCE_NAME DESCRIPTION

65DE6DE3 1222125625 P S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
65DE6DE3 1222125625 P S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
65DE6DE3 1222125625 P S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
65DE6DE3 1222125625 P S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
B0EE9AF5 0305153125 T S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
B0EE9AF5 0305153025 T S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
B0EE9AF5 0305152925 T S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
B0EE9AF5 0305152825 T S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
B0EE9AF5 0305152725 T S hdisk# REQUESTED OPERATION CANNOT BE PERFORMED
 

The detailed error sense data contain SCSI status 18 as demonstrated in the example below.

errpt -a | more

LABEL: SC_DISK_ERR10
IDENTIFIER: 65DE6DE3

... skipped lines..

PATH ID
0
SENSE DATA
0X00 2800 0000 000X 0000 0X0X 0000 0000 0000 0000 0000 0000 0X18 000X 0000 0000
...

 

Sense Data Decoding:

28   # SCSI command opcode: READ(10) or     2A  # SCSI command opcode: WRITE(10)

18   # SCSI status: RESERVATION CONFLICT

 

 

Cause


The error entries indicate a reservation conflict on a path to an MPIO hdisk device.
 
Reservation conflicts typically occur in environments where multiple initiators (e.g., AIX hosts, Fibre Channel adapter ports, or processes) attempt to access or open a shared disk concurrently.

If an initiator places a reservation on a disk, it restricts access to other initiators, resulting in operational errors.
This scenario is common in clustered environments like HACMP or GPFS, where shared disk access is routine.
 
 
Common Causes

1. SCSI-2 Reservation or Reserve Policy Misconfiguration

If SCSI reservation methodology is employed when the MPIO device is opened, this can lead to reservation conflict.
The SCSI-2 reservation policy locks the device to a single initiator (path), and commands routed through any other path result in a reservation conflict.
The reserve_policy attribute determines the reservation behavior:
  • single_path: Reserves the disk for one path, potentially causing conflicts in shared environments.
  • no_reserve: Allows concurrent access, reducing conflicts.
For more information, see MPIO device attributes.
 

2. Stale Reservation

A stale reservation on the storage or an incorrect reserve_lock / reserve_policy may be left in the kernel.
Even with no_reserve configured, stale reservations may persist if a process or initiator does not correctly release the disk.
 

3. Missing Storage Fileset(HAK)
 
Storage Host Attachment Kit (HAK) for AIX is a software pack that simplifies the task of connecting an IBM AIX host to a storage system.
The HAK provides a set of command-line interface tools that help host administrators perform different host-side tasks, such as: detect any physically
connected storage system (single system or multiple systems), detect storage volumes, define the host on the storage system, run diagnostics, and apply best
practice native multi-path connectivity configuration on the host.
When non-IBM storage is presented to AIX without the vendor’s Host Attachment Kit (HAK), AIX defaults to single_path reservation.
This can lead to conflicts unless the correct ODM storage definitions are installed.
 

Answer


To check and release the reservation on a disk, use the following approach:
 
1. Ensure the storage HAK is installed on the AIX server. 
Contact your vendor storage support to supply you with the appropriate storage HAK.
 
2.  Use lsattr -El hdisk# -a reserve_policy to verify the current reserve policy. 
If the disk is shared between multiple initiators, set the policy to no_reserve as recommended in IBM AIX MPIO Best Practices and Considerations.
 
3. If the reserve_policy is set to no_reserve and the problem persist, use devrsrv command to identify and clear the stale reservation.
 
 
Need Further Assistance?
If the above steps do not resolve the issue, open a case with IBM Support.
Please be sure to collect a snap from the affected AIX server and upload it to your case as instructed here.
 

Recommended Documentation:
 
 

[{"Type":"MASTER","Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG10","label":"AIX"},"ARM Category":[{"code":"a8m0z000000cvzSAAQ","label":"Device Configuration"},{"code":"a8m0z000000cw0FAAQ","label":"IO Device Drivers"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"},{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8mKe000000TN3DIAW","label":"MPIO"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
08 January 2026

UID

ibm17230790