IBM Support

Installation of Rational products fail with error "Another version of this product is already installed..."

Troubleshooting


Problem

Attempts to install an IBM Rational product result in the error "Another version of this product is already installed...".

Symptom

The full error message is as follows:

Another version of this product is already installed.  Installation of this version cannot continue.  To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.

Cause

The IBM Rational product has been previously installed on the system but the uninstall of the Microsoft Visual Studio 6 Runtime failed.

The problem is commonly seen when the application has been installed/uninstalled using 3rd party software.

Resolving The Problem

Disclaimer

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986

Search the Windows registry for an entry with a value of 7BBB4910-D21F-430F-92E6-7CA94CE3191C.

To search the registry:

  1. Open the Windows Registry Editor by clicking Start > Run > type regedit
     
  2. Click My Computer
     
  3. Click Edit > Find, and enter 7BBB4910-D21F-430F-92E6-7CA94CE3191C
 

If a match is returned, the Microsoft Visual Studio 6 Runtime is still present on the system and needs to be removed.

To remove the Microsoft Visual Basic 6 Runtime, perform the following:

  1. Launch a Windows command prompt by clicking Start > Run > type cmd
     
  2. Change directory to C:\Windows\System32
    For example: cd \windows\system32
     
  3. Enter the following command to remove the runtime library

    msiexec.exe /x {7BBB4910-D21F-430F-92E6-7CA94CE3191C} /qn ALLUSERS=1 ARPSYSTEMCOMPONENT=1 REBOOT=ReallySuppress
     
  4. If prompted to shut down applications, select "Yes" to close the application being prompted to shut down in order to allow the removal to complete.

Note: If the problem persists after uninstalling the Visual Studio 6 Runtime, refer to technote 1409223 for instructions on removing other components that could cause similar behavior.

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.0.1;7.1.0.2;7.1.1;7.1.1.1;7.1.1.2;7.1.1.3;7.1.1.4;7.1.1.5;7.1.2;7.1.2.1;7.1.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
01 October 2019

UID

swg21496764