IBM Support

Websheet Fails to Load in Planning Analytics as a Service - Failed to open the target workbook

Troubleshooting


Problem

An error is encountered opening a websheet in Planning Analytics as a Service: "Failed to open the target workbook"
 

Symptom

  • Report works in Planning Analytics for Excel
  • Report does not work in Planning Analytics Spreadsheet Service
     

Cause

  • In Planning Analytics as a Service (database version 12+), the database name is now case sensitive
    • See: https://www.ibm.com/docs/en/planning-analytics/2.0.0?topic=12-changed-features-components-in-tm1-database
       

Resolving The Problem

  • Review the formulas in your websheet in Planning Analytics for Excel
  • Ensure all formulas that reference the Planning Analytics database name, reference the database using the correct case
    • Correct case can be seen when connecting to the database in Planning Analytics for Excel and in the Task Pane
  • Publish updated book to the Planning Analytics database

Document Location

Worldwide

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Document Information

Modified date:
04 March 2025

UID

ibm17184782