IBM Support

HSM migration of data set fails with ARC1581I error indicating authorization failure

Troubleshooting


Problem

Customer had not initiated any new migrate to cloud commands for over 3 months.  
After many days of not migrating to the cloud, the first migrate data set command failed with the following errors:
ARC1581I UNEXPECTED HTTP STATUS 401 DURING A GET FOR URI
ARC1581I (CONT.) https:/cloud.name.com/auth/v1.0 ERRTEXT HTTP/1.1 401
ARC1581I (CONT.) Unauthorized
ARC1001I user.data.set.name MIGRATE FAILED, RC=0008, REAS=0018
ARC1208I ERROR ALLOCATING MIGRATION COPY 

Cause

The unauthorized failure is being returned from the DS8000 and Cloud interface.

Environment

DFSMShsm 
DS8K Cloud 
TS7700 
DS8000 Cloud

Resolving The Problem

The best way to confirm whether or not there is an error with the credentials for the Cloud: 
  • Issue the following HSM SETSYS command: 
    • HSEND SETSYS CLOUD(NAME(cloudname) CCREDS)
  • Respond to the message asking for the credentials.  When providing credentials, place a single quote around the entire string of credentials. 
    • NOTE:  No messages are returned to the user if the command was successful.   
NEXT:  
  • Try the HMIGRATE of a data set to the cloud again and it should succeed. 
    • If it does not, there could be another issue between the z/OS host and the DS8000 cloud.   Verify the credentials on the hardware side to confirm they match what is being used on the z/OS host.  

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB56","label":"Z HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG90","label":"z\/OS"},"ARM Category":[{"code":"a8m0z00000009nzAAA","label":"DFSMS-\u003EHSM"},{"code":"a8m0z0000000AHoAAM","label":"DFSMS-\u003EHSM-\u003EMigration"}],"ARM Case Number":"TS018399863","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"2.5.0;3.1.0"}]

Document Information

Modified date:
31 January 2025

UID

ibm17182296