IBM Support

Dealing with upgrades from Windows 10 Devices to Windows 11 through Intune

Troubleshooting


Problem

Windows 10 to Windows 11 feature upgrade through Intune the installation becomes non-responsive.

Symptom

During the feature upgrade installation process, observe system freezes during the installation phase This can be from 1% to 100% during the process.  

Cause

System “corruption” involving the feature manifest, System Distibution and Catroot2 folders.

Environment

Windows 10

Diagnosing The Problem

Checking for feature “corruption” run the following commands
1. Run dism /online /cleanup-image /scanhealth
2. Run dism /online /cleanup-image /checkhealth
Checking the Summary section in the CBS logs saw corruption with some of the files in the manifest.
To repair the system connected to the internet, ran the following:
DISM.exe /Online /Cleanup-image /Restorehealth 
sfc /scannow
Checking the CBS logs, no longer seeing the “corruption” in the Summary section and SFC comes back good.
Testing the feature update, still becoming non-responsive ate 100% into the upgrade process.
Next Cleared the Windows Update Cache using the following method.
Press the Windows key + X and select “Command Prompt (Admin)” from the menu.
Type the following commands and press Enter after each:
  • net stop wuauserv
  • net stop cryptSvc
  • net stop bits
  • net stop msiserver
  • ren C:\Windows\SoftwareDistribution SoftwareDistribution.old
  • ren C:\Windows\System32\catroot2 catroot2.old
  • net start wuauserv
  • net start cryptSvc
  • net start bits
  • net start msiserver
  • Close the Command Prompt and restart your computer
Once complete, the feature update was able to complete as expected.
 

Resolving The Problem

Issue resolved by addressing the “corruption” of the operating system features manifest and files using DISM and SFC combined with clearing Windows Update Cache.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB66","label":"Technology Lifecycle Services"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SSTIPK","label":"Microsoft Windows"},"ARM Category":[{"code":"a8mKe000000004SIAQ","label":"Other Applications"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
10 February 2025

UID

ibm17181717