IBM Support

Fixing Privilege Manager On-Prem installation failure when using System database

Fix Readme


Abstract

The article describes how to fix Privilege Manager On-Prem installation failure when using any default System database.

Content

Product Type: On Premises
Product: Privilege Manager
Known Environments: Privilege Manager On-Prem
Issue

Privilege Manager On-Prem installation fails when using a System database.

Cause 
The installation fails because Microsoft made changes to prevent adjusting the settings of the following database properties:
  • Allow Snapshot Isolation
  • Is Read Committed Snapshot On

These properties are typically set to "True" through the Privilege Manager installation script. Note that the properties can still be set to "True" on a non-System database.

Resolution 

When attempting to install on a System database and it fails, make sure to backup the System database and create a copy of it with a non-System name, then re-run the installation with the new user (non-System) database.

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Document Information

Modified date:
22 November 2024

UID

ibm17176925