Troubleshooting
Problem
After a WebSphere 9.0 fixpack update is applied, HTTP servers associated with a WebSphere 9.0 server fail to start and throw a 'HTP8091 HTTP Server post -configuration step failed' error.
Cause
This issue is typically caused when the HTTP Apache server attempts to read the plugin-cfg.xml file for the associated WebSphere server at startup. This plugin file references a TLS keystore location, in order to secure the communication between HTTP and WebSphere, and the keystore file may not exist. When this occurs the reading of the plugin fails and it terminates the HTTP Apache server job.
Resolving The Problem
To generate the missing keystore we can do the following steps within the WebSphere Administrative Console:
1) From the IBM i Web Administration GUI (http://systemname:2001/HTTPAdmin or https://systemname:2010/HTTPAdmin) click on 'Manage' --> 'Application Servers'. Select your WebSphere server from the server drop down list.
2) On the bottom of the left menu click 'Launch Administrative Console' (NOTE: This will cause a browser popup that is often blocked, you will need to select the option to allow the popup).
3) Sign into the WebSphere Administrative Console.
4) In the left-hand menu in the WebSphere console click 'Servers' --> 'Server Types' --> 'Web Servers'.
5) Click the name of the IHS server on the right side of the screen.
6) Under 'Additional Properties' click 'Plug-in properties'.
7) Click the button labeled 'Copy to Web server keystore directory' under the 'Plug-in key store file name' parameter. This will copy the missing kdb file to the IFS directory that we needed.
8) On the left menu click on 'Web Servers' again under 'Servers' --> 'Server Types'.
9) Check the box next to your IHS server and then click 'Generate Plug-in'. Once that completes, check the box again and then click 'Propagate Plug-in'.
10) We then want to exit the console and restart both the HTTP server and WebSphere server on the IBM i and we can see if things start as expected.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CHUAA2","label":"WebSphere Application Server"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
11 September 2024
UID
ibm17168192