IBM Support

Frequent 401 Unauthorized client error reported at WebHook endpoints

Troubleshooting


Problem

OMS Inventory service has been setup to publish events to external webhooks. The WH endpoints reported frequent 401 Unauthorized client errors.

Symptom

The WH endpoints reported frequent 401 Unauthorized client errors related to auth token expiry.

Cause

The issue is due to the auth token refresh interval at the OMS Inventory service(IV) does not match with the TTL setup at the WH endpoints.
The IV auth token refresh interval was initial setup at the onboarding time. The customer who owns the WH may change the auth token TTL at a late time and resulted the mismatch.

Resolving The Problem

There are two options to avoid such error.
1. Open support ticket to IBM to adjust the auth token refresh interval.
2. return "expires_in" as part of the auth token response to auto update the token refresh timing.

Document Location

Worldwide

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Document Information

Modified date:
18 September 2024

UID

ibm17166864