Troubleshooting
Problem
Application jobs are failing with error msgCPF950A indicating that the maximum size of a Data Queue has been exceded.
Symptom
Jobs sending entries to a Data Queue fail with error message msgCPF950A Storage limit exceeded for data queue &1 in &2
Cause
The maximum storage size for a Data Queue has been exceded.
Resolving The Problem
The recovery actions for this error are as follows:
- Use the Receive Data Queue (QRCVDTAQ) API to receive messages from the Data Queue with the option to remove them.
- If the previous action is not an option, you can use the following steps to Clear the Contents of the entire data queue.
Run the following SQL:
CALL QSYS2.CLEAR_DATA_QUEUE('DataQue1', 'LIBA');
NOTE: Where DataQue1 is the name of the Data Queue and LIBA is the library for the Data Queue.
NOTE 2: All messages from the Data Queue are removed.
The CLEAR_DATA_QUEUE procedure clears all messages from the specified data queue. This procedure provides function similar to the Clear Data Queue (QCLRDTAQ) API.
More information on the CLEAR_DATA_QUEUE procedure:
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CHjAAM","label":"Job and Work Management"}],"ARM Case Number":"TS016802203","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.3.0;7.4.0;7.5.0"}]
Was this topic helpful?
Document Information
Modified date:
24 July 2024
UID
ibm17161435