IBM Support

QRadar on AWS Error - The backup GPT table is not at the end of the disk

Troubleshooting


Problem

While installing QRadar on AWS we get below error after running the setup command.

The backup GPT table is not at the end of the disk, as it should be. This might mean that another operating system believes the disk is smaller. Fix, by moving the backup to the end.

Cause

The QRadar setup script will not able to fix this issue while running the setup and causes installation to fail.

Error: The backup GPT table is not at the end of the disk, as it should be. This might
mean that another operating system believes the disk is smaller. Fix, by moving the backup to the end (and removing the old backup)?
Fix/Ignore/Cancel? 

Environment

QRadar virtual appliance on an Amazon Web Services (AWS) instance by using the provided Amazon Machine Image (AMI)

Diagnosing The Problem


You will get below error after running the setup command and installation won't proceed. 
Error: The backup GPT table is not at the end of the disk, as it should be. This might
mean that another operating system believes the disk is smaller. Fix, by moving the backup to the end (and removing the old backup)?
Fix/Ignore/Cancel? 

After cancelling you will not be able to run the setup again it will give the error as:

Checking for attached second disk
ERROR:  second disk contains existing partitions
Attach a second disk with no existing partitions and try again.

So you need to deploy the AWS Virtual machine from scratch with a second disk or data disk.

Resolving The Problem

Configure an IBM® QRadar virtual appliance on an Amazon Web Services (AWS) instance by using the provided Amazon Machine Image (AMI) with a second Disk or Data disk.
Refer the Link: https://www.ibm.com/docs/en/qsip/7.5?topic=qcmi-configuring-qradar-750-up4-virtual-appliance-amazon-web-services

Before running the setup to install the virtual appliance. Run the below command to cross-check the GPT partition Error:

Run this command to validate the second disk:
lsblk

Run this command to check the disk partition:
#parted

Print all tables using below command:
print all

Error: The backup GPT table is not at the end of the disk, as it should be. This might
mean that another operating system believes the disk is smaller. Fix, by moving the backup to the end (and removing the old backup)?
Fix/Ignore/Cancel? 

If the above error is prompted follow the instructions, Enter "Fix" twice to resolve GPT related error.
It will fix the error and move the backup of GPT table to the end of the table.

Run this command to come out from parted utility:
quit

To validate run again:
#Parted

Print all tables using below command:
print all

If an error is not prompted run the setup command with the respective appliance type ID for the Virtual appliance.
#sudo /root/setup <appliance_id>

After this your installation should proceed successfully. 
If you still have any issues, contact support.

Document Location

Worldwide

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Document Information

Modified date:
25 April 2024

UID

ibm17148181