Troubleshooting
Problem
WinCollect service is unable to start after a reinstallation, the following error is seen:
Windows could not start the Wincollect service on Local Computer.
Error 1067: The process terminated unexpectedly.
Error 1067: The process terminated unexpectedly.
Symptom
When the Windows administrator tries to start the WinCollect process, for example, through the Windows Services, a pop-up message similar to the following appears:
Cause
The problem is related to a corruption of the RSA key created for the WinCollect application.
Resolving The Problem
- Log in as an Administrator to the Windows server where the WinCollect agent is installed.
- Open PowerShell.
- Run the following command to find the key for WinCollect.
Notes:
• Most of the content of these files is not in plain text.
• The keys are located in C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\.
• The key for the WinCollect agent contains the string WinCollect.ConfigServerConnection.
• If you are not able to see or open the key, then the problem with the WinCollect agent could be the permissions for the key.
Select-String -Path "C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\*" -Pattern "WinCollect"
In the following capture, the key is the one starting with 6c6416ddf7: - Delete the key that contains the string WinCollect.ConfigServerConnection in it, you can also move it outside the C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\ directory.
- Uninstall the WinCollect agent.
-
Verify that the following folders are deleted, if not, go ahead and delete them manually:
C:\Program Files\IBM\WinCollect C:\ProgramData\WinCollect
-
Reinstall the WinCollect agent.
Result:
The WinCollect agent service is able to start without any error. If the issue persists, contact QRadar Support for assistance.
Document Location
Worldwide
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Document Information
Modified date:
12 April 2024
UID
ibm17145201