Troubleshooting
Problem
Administrators who are upgrading their QRadar appliances found this YUM transactional error "database disk image is malformed"
Cause
The YUM (Yellowdog Updater, Modified) transaction database is corrupted.
Diagnosing The Problem
To confirm if the database is OK or corrupted, run the following steps:
- Login to the QRadar Console as the root user.
- Optional: Use SSH to log in to the respective managed host if it is not t'he QRadar Console.
- Check the YUM transactional SQLITE3 database integrity, run the following command:
sqlite3 /var/lib/yum/history/history-*.sqlite "PRAGMA integrity_check"
Ok
Result
The administrator knows the health status of the YUM transactional SQLITE3 database. If the database is corrupted, move to the Resolving The Problem section.
Resolving The Problem
The YUM transactional history records all YUM transactions for audit purposes and enables YUM to undo or replicate transactions. Removing this history to recreate it does not impact the system functionality.
To fix the YUM transactional database error, run the following steps on the affected appliance:
- Login to the QRadar Console as the root user.
- Optional: Use SSH to log in to the respective host if it is not the QRadar Console.
- Create a backup directory:
mkdir -pv /store/ibm_support/yum_hist
- Move the YUM transactional history to a backup directory:
mv /var/lib/yum/history /store/ibm_support/yum_hist/history_backup
- Recreate the YUM transactional history directory:
mkdir -pv /var/lib/yum/history
- Fix the permissions for the YUM transactional history directory:
chmod 0755 /var/lib/yum/history
- Fix the ownership for the YUM transactional history directory:
chown root:root /var/lib/yum/history
Result
The YUM transaction history has been reset; subsequent transactions will initiate a fresh history log. If the issue persists, contact QRadar Support for assistance.
Document Location
Worldwide
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Document Information
Modified date:
12 April 2024
UID
ibm17145116