Troubleshooting
Problem
IBM Installation Manager users may get the "./imcl: Permission denied" error when running any IBM Installation Manager 'imcl' command.
Symptom
IBM Installation Manager users may get the "./imcl: Permission denied" error when running any IBM Installation Manager (IM) 'imcl' command. The error will happen running IM in a 'user' mode or when running as root 'admin' user.
Viewing the IM installation folder with 'ls -l' output will show proper execute permissions for user and root. The user that owns all the IM installed files will also see permission denied in user and root modes.
Cause
This error happens when the file system where Installation Manager is installed is mounted with the 'noexec' mount option. Mounting in this way will disallow executing any commands in the mounted folder in spite of permissions and file ownership.
Environment
This has been seen on Linux systems but could happen on any Operating System that allows mount of folders or filesystems with the 'noexec' option.
Diagnosing The Problem
Run this command to determine if the IBM Installation Manager install folder is mounted as 'noexec':
mount | grep noexec
Resolving The Problem
Remount the folder that will contain IBM Installation Manager install artifacts without the 'noexec' mount option.
Document Location
Worldwide
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Document Information
Modified date:
28 February 2024
UID
ibm17124698