IBM Support

Running imcl commands fail with "imcl: Permission denied" if directory where Installation Manager is installed is mounted with 'noexec' mount option

Troubleshooting


Problem

IBM Installation Manager users may get the "./imcl: Permission denied" error when running any IBM Installation Manager 'imcl' command.

Symptom

IBM Installation Manager users may get the "./imcl: Permission denied" error when running any IBM Installation Manager (IM) 'imcl' command. The error will happen running IM in a 'user' mode or when running as root 'admin' user.

Viewing the IM installation folder with 'ls -l' output will show proper execute permissions for user and root.  The user that owns all the IM installed files will also see permission denied in user and root modes.

Cause

This error happens when the file system where Installation Manager is installed is mounted with the 'noexec' mount option.  Mounting in this way will disallow executing any commands in the mounted folder in spite of permissions and file ownership.

Environment

This has been seen on Linux systems but could happen on any Operating System that allows mount of folders or filesystems with the 'noexec' option.

Diagnosing The Problem

Run this command to determine if the IBM Installation Manager install folder is mounted as 'noexec':
   mount | grep noexec

Resolving The Problem

Remount the folder that will contain IBM Installation Manager install artifacts without the 'noexec' mount option.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB67","label":"IT Automation \u0026 App Modernization"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSDV2W","label":"IBM Installation Manager"},"ARM Category":[{"code":"a8m3p000000PCNXAA4","label":"INSTALLATION-CONFIGURATION-MIGRATION"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions"}]

Document Information

Modified date:
28 February 2024

UID

ibm17124698