IBM Support

QRadar SOAR: AADSTS50011 error returned by Azure when configuring inbound email

Troubleshooting


Problem

During the process of configuring inbound email for QRadar SOAR or Cloud Pak for Security an error might be returned by Azure if the Azure application has not been configured correctly.

Symptom

An error such as this might be seen during the configuration of inbound email.
AADSTS50011: The redirect URI 'https://<SOAR OR CP4S FQDN>/email-oauth' specified in the request does not match the redirect URIs configured for the application '2935238f-9889-4d8e-a9d7-1234567qa1'. Make sure the redirect URI sent in the request matches one added to your application in the Azure portal. Navigate to https://aka.ms/redirectUriMismatchError to learn more about how to fix this.

Cause

The error is returned by Microsoft Azure and is caused by misconfiguration of the application in Azure.

Diagnosing The Problem

Have your Azure administrator check what they have set in Redirect URIs for the Azure application.
This image shows where the setting is configured in Azure for a QRadar SOAR deployment.
Azure redirect URI

Resolving The Problem

The following is taken from the IBM documentation for both products.
QRadar SOAR
If you are using the Azure platform, you need to enter the SOAR Platform URL with /email-oauth appended at the end when you register the application and enter the redirect URI.
Cloud Pak for Security
If you are using the Azure platform, you must enter the IBM Security QRadar Suite base URL with /api/respond/email-oauth appended at the end when registering the application and entering the redirect URI.
In these instances, the Azure application was not configured with the correct Redirect URI.
Be aware that the values in the documentation are case sensitive.

Document Location

Worldwide

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Document Information

Modified date:
23 February 2024

UID

ibm17123155