Question & Answer
Question
Why does scan import fail with message: Failed to list files
Cause
At times when you attempt to import scan report from a target scanner to QRadar from Admin > VA Scanners, it fails with the following message in the file:
/var/log/qradar.log
Jul 14 16:32:17 ::ffff:127.0.0.1 [vis] [Scanner Manager] com.q1labs.vis.ScannerManager: [ERROR] [NOT:0000003000][<Qradar_HostIP>/- -] [-/- -]Could not initialize scanner 'scanner@N.N.N.N': Could not list files in Nessus results directory, due to: Failed to list files
Jul 14 16:32:17 ::ffff:127.0.0.1 [vis] [Scanner Manager] com.q1labs.vis.exceptions.ScannerInitException: Could not initialize scanner 'scanner@N.N.N.N': Could not list files in Nessus results directory, due to: Failed to list files
Jul 14 16:32:47 ::ffff:127.0.0.1 [vis] [Schedule Manager] com.q1labs.vis.ScheduleManager: [INFO] [NOT:0000006000][<Qradar_HostIP>/- -] [-/- -]Received scan update response from scanner@N.N.N.N scanner with config id 53 and request id 104 - progress: 0% status: Failed
The reason for the error message is because the scanned report files are not available at the specified location on the target scanner.
Answer
Make sure that the scanner report files are available at the specified location on the target scanner before you import.
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwtNAAQ","label":"Deployment"},{"code":"a8m0z000000cwtKAAQ","label":"QRadar Risk and Vulnerability Manager"}],"ARM Case Number":"TS013607107","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions"}]
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Document Information
Modified date:
15 December 2023
UID
ibm17096502