Troubleshooting
Problem
I queried my table and found data exists for the relevant KPI. However when I run the report, it returns an error stating "No data found".
Symptom
Report results are reporting "no data found" but querying the database table, data does indeed exist.
Cause
The KPI selected in the definition report may not represent the correct data we are looking for. Although it is rare, there are instances where more than one techpack can share the same KPI name. This is even more so when you have different technologies installed but referencing the same vendor.
Resolving The Problem
Ensure you know the techpack for which your KPI selection is based on.
The example below depicts a KPI selected from the UMTS Ericsson MGW R5.1 techpack.
To ensure you select the correct KPI within the correct focal entity in your report definition, do the following:
1. Retrieve the Functional Specification (FS) documentation that is packaged with your techpack.
2. Search for the KPI name in FS. In this example, the KPI name is "pmNoOfSIOSIFTransmitted".
3. Once you find the KPI, determine the entity it belongs to by scrolling up to the top of the table where the KPI is contained.
4. The FS snapshot of the KPI and entity are shown as below:
5. The entity you need to select in your report definition is Signalling Point.
6. Create the report again but now choose the correct entity. You should also be able to find the relevant KPI as well.
7. Run the report and ensure there are results being displayed instead of the "no data found" message.
Was this topic helpful?
Document Information
Modified date:
21 June 2018
UID
swg21589785