Troubleshooting
Problem
Upgrading large deployments in parallel can sometimes cause upgrade failures on some managed hosts.
Symptom
Some managed hosts fail the upgrade during pre-check.
Cause
The problem is due to the managed hosts need to connect to the console's tomcat service during the initial upgrade pre-check. With so many managed hosts upgrading in parallel and trying to connect to console's tomcat service at the same time, sometimes the connection can fail on some managed hosts. The upgrade pre-check will not reattempt to connect and fails the upgrade instead. This issue is more likely to occur when upgrade using all_server command to initiate the installer.
Environment
Large deployments of over 50 managed hosts
Diagnosing The Problem
On the managed host, in the /var/log/setup.xxxxxxxx/patch.log:
Jul 27 09:30:44 2023: Jul 27 09:30:44 2023:[ERROR] Failed to connect to tomcat
Resolving The Problem
Manually re-run the installation on the managed host:
- SCP the upgrade file from console to the managed host:
scp /storetmp/<upgrde file> managedHostIP:/storetmp
- To create the /media/updates directory, type the following command:
mkdir -p /media/updates
-
To mount the file to the /media/updates directory, type the following command:
mount -o loop -t squashfs /storetmp/<upgrade file> /media/updates
-
To run the patch installer, type the following command:
/media/updates/installer
Document Location
Worldwide
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Document Information
Modified date:
11 December 2023
UID
ibm17082703