IBM Support

IBM Software products installed together that share a common environment

Question & Answer


Question

Which IBM Software products installed together can share a common environment?

Answer

Sharing an environment between products - overview:
When you use IBM Installation Manager to install a product, in some cases it is possible to install the product into a package group (installation location) that is used by one or more products that are already installed on your computer. For example, products might be able to share a package group is if they are Eclipse-based, use the same Eclipse version and the features that comprise the products do not conflict with each other.

If multiple products are installed into the same package group, then when you run one of the products the user interface and features contributed by the other products are visible; the products share a common environment. (Sometimes this type of sharing is known as shell sharing.)
Installation Manager determines for you if a product can be installed in the same package group as another product.



Comparing products that share a common environment with products that coexist on the same computer
:
If you install two products into different package groups, then the products coexist on the same computer but they do not share a common environment. Therefore, if you start one of the products you will not see the user interface or features of the other product; you see the interface only for the product that you started. Also, any components that exist in both products are updated separately

Note that, in cases where it is possible for a product to share a package group with another product, it is not necessary to install them in the same package group; you can choose to install the products into separate package groups.


Comparing product extensions with products that share a common environment
:
Product extensions provide additional functionality to another prerequisite product package. By design, a product extension must be installed into the same package group as its prerequisite product; you cannot install a product extension on its own.


General considerations on sharing common environment
Here are some details to consider when installing multiple products in the same package group:

Install the latest available updates for products that share an environment:

If you install a newer release of a product with in the same package group as a product that is at an earlier version, you might experience problems when working with the products. These problems can occur because components that are shared between the products might not be at version that is compatible with both versions of the installed products..
In general, you can avoid these problems by installing the latest available updates for all products that share a common environment. Refer to the lists below of product versions that are expected to share a common environment successfully.

Installation Manager might prevent updates to products in a shared environment:

If you update one product in package group that is shared by two or more products, then any features that are shared between products might be updated. For this reason, Installation Manager might not allow updates in some cases due to the dependency requirements of the products in the package group.

Known problems or limitations with sharing common environments:




Shared environment combinations that are expected to work successfully

The following tables list groups of products at specific version levels that (with caveats as noted) are expected to not conflict with each other when installed together into the same Installation Manager Package Group (Eclipse instance) - the practice referred to as "shell sharing". For information about the compatibility of these products with other, non-Eclipse-based software (such as operating systems, browsers, and runtime test environments) see each product's System Requirements information.




Products based on Eclipse 4.6.1 on Java 8
NOTE: Due to the change of Eclipse the 9.6 versions of any of these products will not shell-share with the 9.5.x or earlier versions of any of these same products:
  • IBM Rational Application Developer for WebSphere Software
  • IBM Rational Software Architect Designer for WebSphere Software
  • IBM Rational Software Architect Designer (and Extension offerings)
  • IBM Rational Developer for z Systems
  • IBM Rational Developer for i
  • IBM Rational Business Developer

Compatibility Group #1:
  • IBM Rational Application Developer for WebSphere Software 9.6.x (**), (***), (****), (*****)
  • IBM Rational Software Architect Designer for WebSphere Software 9.6.x (**), (***) (****)
  • IBM Rational Software Architect Designer (and Extension offerings) 9.6.x
  • IBM Rational Team Concert Client 5.0.2 or 6.0.2 (*)
  • IBM Developer for z Systems 14.1.x (**), (***)
  • IBM Developer for i 9.6.x (*****)

(*) Applies to Rational Team Concert
Rational Team Concert must be installed using p2 install.

(**) Applies to IDz, RAD, and RSA
IBM Developer for z Systems 14.1.x is not compatible with Rational Application Developer/Rational Software Architect 9.6.1 for shell sharing.

(***) Applies to RAD and IDz
Shell sharing install where Rational Application Developer 9.6.1.1 and IBM Developer for z Systems 14.1.1 or 14.1.2 are both installed into the same package group fails.

(****) Applies to RAD and RSA
Shell sharing install for Rational Application Developer 9.6.1.1 and Rational Software Architect 9.6.1 fails.

(*****) Applies to RAD and RDi
(1) Shell sharing between Rational Developer for i 9.6.0.2 and Rational Application Developer 9.6.1.1, when only RDi RPG and COBOL Tools features are selected, fails if you install Rational Application Developer 9.6.1.1 first. Shell sharing works if you install Rational Developer for i 9.6.0.2 before Rational Application Developer 9.6.1.1.
(2) Installing Rational Application Developer 9.6.1 and Rational Developer for i 9.6.0.1 in the same package group and then updating to Rational Application Developer 9.6.1.1 and Rational Developer for i 9.6.0.2 at the same time, when only RDi RPG and COBOL Tools features are selected, works.
(3) Installing Rational Application Developer 9.6.1.1 first and then installing Rational Developer for i 9.6.0.2 in the same package group, when only RDi RPG and COBOL Tools features are selected, does not work.
(4) Installing Rational Developer for i 9.6.0.2 first and then installing Rational Application Developer 9.6.1.1 in the same package group, when only RDi RPG and COBOL Tools features are selected, works.
(5) Installing Rational Application Developer 9.6.1 and Rational Developer for i 9.6.0.1 in the same package group and then updating to Rational Application Developer 9.6.1.1 and Rational Developer for i 9.6.0.2, when RDi Modernization Tools - Java Edition selected are installed, does not work.


The following are also Group 1 compatible and, with caveats as noted, are supported for shell sharing (that is, IBM will open support tickets for issues arising in shell-sharing scenarios involving these products together with the Group 1 products listed above). However, in practice these are less commonly shell-shared with the above products, and thus these scenarios have been less rigorously tested, which increases the risk that you may encounter issues.
  • IBM Rational Clear Case / CTE 8.0.1.x (x >= 13) or 9.0.0.x (x >= 3)




Products based on Eclipse 4.4.2 on Java 8
NOTE: Due to the change of Eclipse the 9.5 versions of any of these products will not shell-share with the 9.1.x versions of any of these same products:
  • IBM Rational Application Developer for WebSphere Software
  • IBM Rational Software Architect Designer for WebSphere Software
  • IBM Rational Software Architect Designer (and Extension offerings)
  • IBM Rational Developer for z Systems
  • IBM Rational Developer for i
  • IBM Rational Business Developer

Compatibility Group #1:
  • IBM Rational Application Developer for WebSphere Software 9.5.x (***)
  • IBM Rational Software Architect Designer for WebSphere Software 9.5.x (**)
  • IBM Rational Software Architect Designer (and Extension offerings) 9.5.x (**)
  • IBM Rational Developer for z Systems 9.5.x (**)
  • IBM Developer for z Systems 14.0 (**)
  • IBM Rational Developer for i 9.5.x (**)
  • IBM Rational Business Developer 9.5.x
  • IBM Rational Team Concert Client 5.0.2.x (*), 6.0.x
  • IBM Rational Host Access Transformation Services 9.5.0.x
  • IBM Data Studio 4.1.2.x
  • IBM InfoSphere Data Architect 9.1.3.x ok

(*) - Workaround: Rational Team Concert 5.0.2 clients do not install into Eclipse 4.4 package groups
(**) - Rational Developer for z Systems v9.5.1 and IBM Developer for z Systems v14.0 have known shell sharing limitations with Rational Software Architect v9.5 and Rational Developer for i v9.5
(***) - Rational Application Developer for WebSphere Software 9.5.0.2 (RAD) has a shell share issue. Customers are advised to install RAD 9.5.0.2 iFix 1 instead (RAD 9.5.0.2 iFix 1)

The following are also Group 1 compatible and, with caveats as noted, are supported for shell sharing (that is, IBM will open support tickets for issues arising in shell-sharing scenarios involving these products together with the Group 1 products listed above). However, in practice these are less commonly shell-shared with the above products, and thus these scenarios have been less rigorously tested, which increases the risk that you may encounter issues.

  • IBM Rational Clear Case / CTE 8.0.1.x (x >= 8)


Remark: RTC is not based on Eclipse 4.4.2 or Java 8. However, when shell sharing with the other products RTC will run on Eclipse 4.4.2 and Java 8.




Products based on Eclipse 4.2.x on Java 7
NOTE: due to a one-time change to the format of component-level installer metadata formats, the 9.0 versions of any of these products will not shell-share with the 9.1 versions of any of these same products, even though both the 9.0 and 9.1 versions are based on Eclipse 4.2.2:
  • IBM Rational Application Developer for WebSphere Software
  • IBM Rational Software Architect for WebSphere Software
  • IBM Rational Software Architect (and Extension offerings)
  • IBM Rational Developer for System z
  • IBM Rational Developer for i
  • IBM Rational Developer for AIX and Linux
  • IBM Rational Business Developer

Compatibility Group #1:
  • IBM Rational Application Developer for WebSphere Software 9.1.x
  • IBM Rational Software Architect for WebSphere Software 9.1.x
  • IBM Rational Software Architect (and Extension offerings) 9.1.x
  • IBM Rational Developer for System z 9.1.x
  • IBM Rational Developer for i 9.1.x
  • IBM Rational Developer for AIX and Linux 9.1.x
  • IBM Rational Business Developer 9.1.x
  • IBM Rational Team Concert Client 4.0.x (x >= 3), 5.0.x, 6.0.x
  • IBM Rational Host Access Transformation Services 9.0.0.x
  • IBM Data Studio 4.1.0.1, 4.1.1
  • IBM InfoSphere Data Architect 9.1.2
  • IBM Worklight 6.1.0.1, 6.1.0.2 (6.1.0.1 requires an iFix)

Compatibility Group #2:
  • IBM Rational Application Developer for WebSphere Software 9.0, 9.0.x
  • IBM Rational Software Architect for WebSphere Software 9.0(*), 9.0.x
  • IBM Rational Software Architect (and Extension offerings) 9.0.x
  • IBM Rational Developer for System z 9.0(**), 9.0.x
  • IBM Rational Developer for i 9.0
  • IBM Rational Developer for AIX and Linux 9.0
  • IBM Data Studio 4.0.1.x
  • IBM InfoSphere Data Architect 9.1, 9.1.x
  • IBM Rational Business Developer 9.0
  • IBM Rational Team Concert Client 4.0.x (x>=3), 5.0.x, 6.0.x
  • IBM Worklight 6.0.x
  • IBM Rational Host Access Transformation Services 9.0
(*) - RSA 9.0 only works with the other products that are on 9.0
(**) - RDz 9.0 requires an iFix to allow an update of RAD 9.0 to 9.0.1 (Link to iFix)


The following are also Group 1 and Group 2 compatible and, with caveats as noted, are supported for shell sharing (that is, IBM will open support tickets for issues arising in shell-sharing scenarios involving these products together with the Group 1 products listed above). However, in practice these are less commonly shell-shared with the above products, and thus these scenarios have been less rigorously tested, which increases the risk that you may encounter issues.

  • IBM Rational Asset Analyzer 6.1.0.4 (caveat: only supported for shell-share with Rational Developer for System z)
  • IBM Rational Performance Tester 8.5.0.x, 8.5.1.x, 8.6.0.x
  • IBM Rational Service Tester for SOA Quality 8.5.0.x, 8.5.1.x, 8.6.0.x
  • IBM Rational Functional Tester 8.5.0.x, 8.5.1.x, 8.6.0.x
  • IBM Rational Clear Case / CTE 8.0.1.x




Products based on Eclipse 3.6.x on Java 7
Compatibility Group 1:
  • Rational Application Developer for WebSphere Software 8.5
  • Rational Software Architect 8.5
  • Rational Software Architect for WebSphere Software 8.5
  • Rational Developer for System z 8.5
  • Data Studio 3.1.1, 3.2
  • InfoSphere Data Architect 8.1, 8.5
  • Rational Business Developer 8.5
  • Rational Developer for Power Systems Software 8.5
  • Rational Team Concert Client 3.0.1.x (x>=3)
  • Rational Team Concert Client 4.0.x

Compatibility Group 2:
  • Rational Application Developer for WebSphere Software 8.5.1
  • Rational Software Architect 8.5.1
  • Rational Software Architect for WebSphere Software 8.5.1
  • Rational Developer for System z 8.5.1
  • Data Studio 3.1.1, 3.2
  • InfoSphere Data Architect 8.1, 8.5
  • Rational Asset Manager 7.5.1.2
  • Rational Developer for Power Systems Software 8.5.1
  • Rational Team Concert Client 3.0.1.x (x>=3)
  • Rational Team Concert Client 4.0.x
Compatibility Group 3:
  • Rational Application Developer for WebSphere Software 8.5.5.x
  • Rational Software Architect 8.5.5.x (x >=2)
  • Rational Software Architect for WebSphere Software 8.5.5.x (x >=2)
  • Rational Developer for System z 8.5.1.4
  • Rational Business Developer 8.5.1.1
  • Data Studio 3.1.1, 3.2
  • InfoSphere Data Architect 8.1, 8.5
  • Rational Team Concert Client 3.0.x (x>=3), 4.0.x, 5.0.x, 6.0.x



Products based on Eclipse 3.6.x on Java 6
Guideline for product combinations expected to work when installed into the same package group. The products grouped at the time of release and similar common components based on Eclipse 3.6.x.

Compatibility Group 1:
    • Rational Application Developer for WebSphere Software 8.0
    • Rational Application Developer Standard Edition for WebSphere Software 8.0
    • Rational Software Architect 8.0
    • Rational Software Architect for WebSphere Software 8.0
    • Rational Software Architect RealTime Edition 8.0
    • Rational Developer for Power Systems Software 8.0
    • Data Studio 3.1.1
    • Infosphere Data Architect 8.1

Compatibility Group 2:
    • Rational Application Developer for WebSphere Software 8.0.1
    • Rational Application Developer Standard Edition for WebSphere Software 8.0.1
    • Rational Software Architect 8.0.1
    • Rational Software Architect for WebSphere Software 8.0.1
    • Rational Software Architect RealTime Edition 8.0.1
    • Rational Developer for System z 8.0.1
    • Rational Business Developer 8.0.1
    • Data Studio 3.1.1
    • Infosphere Data Architect 8.1

Compatibility Group 3:
    • Rational Application Developer for WebSphere Software 8.0.2
    • Rational Application Developer Standard Edition for WebSphere Software 8.0.2
    • Rational Software Architect 8.0.2
    • Rational Software Architect for WebSphere Software 8.0.2
    • Rational Software Architect RealTime Edition 8.0.2
    • Rational Developer for System z 8.0.2
    • IBM Integration Designer 7.5
    • Data Studio 3.1.1
    • Infosphere Data Architect 8.1
    • Rational Business Developer 8.0.1.1

Compatibility Group 4:
    • Rational Application Developer for WebSphere Software 8.0.3
    • Rational Application Developer Standard Edition for WebSphere Software 8.0.3
    • Rational Software Architect 8.0.3
    • Rational Software Architect for WebSphere Software 8.0.3
    • Rational Software Architect RealTime Edition 8.0.3
    • Rational Software Architect Design Manager 3.0
    • Rational Rhapsody Design Manager 3.0
    • Rational Developer for Power Systems Software 8.0.3
    • Rational Developer for System z 8.0.3
    • IBM Integration Designer 7.5.1
    • Data Studio 3.1.1
    • Infosphere Data Architect 8.1
    • Rational Business Developer 8.0.1.2

Compatibility Group 5:
    • Rational Application Developer for WebSphere Software 8.0.4
    • Rational Application Developer Standard Edition for WebSphere Software 8.0.4
    • Rational Software Architect 8.0.4
    • Rational Software Architect for WebSphere Software 8.0.4
    • Rational Software Architect RealTime Edition 8.0.4
    • Rational Software Architect Design Manager 3.0.0.1
    • Rational Developer for System z 8.0.3.1
    • Rational Rhapsody Design Manager 3.0.0.1
    • Data Studio 3.1.1
    • Infosphere Data Architect 8.1
    • Rational Business Developer 8.0.1.3

Compatibility Group 6:
  • Rational Application Developer for WebSphere Software 8.0.4.1
  • Rational Application Developer Standard Edition for WebSphere Software 8.0.4.1
  • Rational Software Architect 8.0.4.1
  • Rational Software Architect for WebSphere Software 8.0.4.1
  • Rational Software Architect RealTime Edition 8.0.4.1
  • Data Studio 3.1.1
  • InfoSphere Data Architect 8.1
  • Rational Business Developer 8.0.1.4

Compatibility Group 7:
  • Rational Application Developer for WebSphere Software 8.0.4.2
  • Rational Application Developer Standard Edition for WebSphere Software 8.0.4.2
  • Rational Software Architect 8.0.4.2
  • Rational Software Architect for WebSphere Software 8.0.4.2
  • Rational Software Architect RealTime Edition 8.0.4.2
  • Rational Developer for System z 8.0.3.4
Compatibility Group 8:
  • Rational Application Developer for WebSphere Software 8.0.4.3
  • Rational Application Developer Standard Edition for WebSphere Software 8.0.4.3
  • Rational Software Architect 8.0.4.3
  • Rational Software Architect for WebSphere Software 8.0.4.3
  • Rational Software Architect RealTime Edition 8.0.4.3
  • Rational Developer for System z 8.0.3.5
  • Rational Developer for Power 8.0.3.1
  • Rational Business Developer 8.0.1.5

Products based on Eclipse 3.4.x
Guideline for product combinations expected to work when installed into the same package group. The products grouped at the time of release and similar common components based on Eclipse 3.4.x.

Compatibility Group 1:
    • Domino Designer 8.5
    • Rational Application Developer for WebSphere Software 7.5
    • Rational Business Developer 7.5
    • Rational Business Developer¬†7.5.1
    • Rational Data Architect 7.5 (subsequently renamed to InfoSphere Data Architect)
    • Rational Developer for i 7.5
    • Rational Developer for System z 7.5
    • Rational Functional Tester 8.0
    • Rational Insight 1.0
    • Rational Insight Adapter for HP Quality Center Software 1.0
    • Rational Performance Tester 8.0
    • Rational Requirements Composer 1.0
    • Rational Requirements Composer 2.0
    • Rational Robot 7.0.2
    • Rational Service Tester for SOA Quality 8.0
    • Rational Software Architect for WebSphere Software 7.5
    • Rational Software Architect Standard Edition 7.5
    • Rational Software Modeler 7.5
    • Rational Test Manager 7.0.2
    • WebSphere Business Modeler Basic/Advanced 6.2
    • WebSphere Enterprise Service Bus 7.0.0
    • WebSphere Transformation Extender 8.3
    • Rational Developer for i 7.5

Compatibility Group 2:
    • Data Discovery and Query Builder 3.1
    • Data Studio Administrator for DB2 Linux, UNIX, and Windows 2.1
    • Data Studio Developer 2.1
    • DB2 Optimization Expert for z/OS 2.1 (subsequently renamed to Optim Query Tuner)
    • InfoSphere Data Architect 7.5.1
    • Rational Application Developer for WebSphere Software 7.5.1
    • Rational Business Developer V7.5.1.1
    • Rational Developer for System z V7.5.0.1
    • Rational Software Architect for WebSphere Software 7.5.1
    • Rational Software Architect Standard Edition 7.5.1
    • Rational Software Modeler 7.5.1
    • WebSphere Business Modeler v6.2
    • WebSphere Integration Developer 6.2

Compatibility Group 3:
    • Alphablox 9.5.7
    • Data Studio Administrator 2.1.0.1 (subsequently renamed to Optim Database Administrator for DB2 for Linux, UNIX and Windows)
    • Data Studio Developer 2.1.0.1 (subsequently renamed to Optim Development Studio)
    • InfoSphere Data Architect 7.5.1.1 and 7.5.2
    • InfoSphere Warehouse for LUW 9.7
    • Optim Data Privacy Solution 2.1
    • Optim Database Administrator for DB2 for Linux, UNIX and Windows 2.2 and 2.2.1
    • Optim Database Relationship Analyzer for 2.1.0
    • Optim Designer 2.1
    • Optim Development Studio 2.2
    • Optim Query Tuner 2.2
    • Rational Application Developer for WebSphere Software 7.5.2
    • Rational Business Developer V7.5.1.2
    • Rational Developer for System z V7.5.1
    • Rational Software Architect for WebSphere Software 7.5.2
    • Rational Software Architect RealTime Edition 7.5.2
    • Rational Software Architect Standard Edition 7.5.2
    • Rational Software Modeler 7.5.2
    • WebSphere Business Modeler v6.2.0.1
    • WebSphere Business Modeler v6.2.0.2
    • WebSphere Business Monitor v6.2.0.1
    • WebSphere Business Monitor v6.2.0.2
    • WebSphere Integration Developer v6.2.0.1 [*see known limitations above]
    • WebSphere Integration Developer v6.2.0.2 [*see known limitations above]
    • WebSphere Portlet Factory 6.1.5
    • WebSphere Service Registry and Repository 6.3
    • WebSphere Service Registry and Repository 7.0
    • Rational Developer for Power Systems Software 7.5

Compatibility Group 4:
    • Business Process Choreographer 7.0
    • Domino Designer 8.5.1
    • InfoSphere Classic Change Data Capture for z/OS v10.1
    • InfoSphere Classic Federation Server for z/OS V10.1
    • InfoSphere Data Architect 7.5.2.1
    • InfoSphere IMS Replication for z/OS v10.1
    • InfoSphere Warehouse for LUW 9.7
    • Optim Database Administrator for DB2 for Linux, UNIX and Windows 2.2.2
    • Optim Development Studio 2.2.0.1
    • Optim Query Tuner 2.2.0.1
    • Rational Application Developer for WebSphere Software 7.5.3
    • Rational Business Developer V7.5.1.3
    • Rational Developer for System z 7.6
    • Rational Functional Tester 8.1
    • Rational Performance Tester 8.1
    • Rational Service Tester for SOA Quality 8.1
    • Rational Software Architect for WebSphere Software 7.5.3
    • Rational Software Architect RealTime Edition 7.5.3
    • Rational Software Architect Standard Edition 7.5.3
    • Rational Software Modeler 7.5.3

Compatibility Group 5:
    • Rational Application Developer for WebSphere Software 7.5.4
    • Rational Business Developer for V7.5.1.4
    • Rational Developer for Power System Software 7.5
    • Rational Developer for System z 7.5.1.1
    • Rational Software Architect for WebSphere Software 7.5.4
    • Rational Software Architect RealTime Edition 7.5.4
    • Rational Software Architect Standard Edition 7.5.4
    • Rational Software Modeler 7.5.4
    • WebSphere Business Compass v7.0
    • WebSphere Business Modeler v7.0
    • WebSphere Business Modeler v7.0.0.1
    • WebSphere Business WebSphere Business Monitor v7.0
    • WebSphere Integration Developer v7.0
    • WebSphere Integration Developer v7.0.0.1
    • WebSphere Message Broker v7.0
    • WebSphere Process Server v7.0
    • WebSphere Process Server v7.0.0.1
    • Rational Developer for Power Systems Software 7.5

Compatibility Group 6:
    • ILOG ODM Enterprise v3.4
    • Rational Application Developer for WebSphere Software 7.5.5
    • Rational Developer for System z 7.6.0.1
    • Rational Functional Tester 8.1.1
    • Rational Performance Tester v8.1.1
    • Rational Software Architect for WebSphere Software 7.5.5
    • Rational Software Architect RealTime Edition 7.5.5
    • Rational Software Architect Standard Edition 7.5.5
    • Rational Software Modeler 7.5.5
    • Rational Developer for i 7.5.0.6
    • Rational Developer for Power Systems Software 7.6

Compatibility Group 7:
    • IBM Optim Development Studio 2.2.0.2, 2.2.0.3, 2.2.1.0
    • IBM Rational Developer for System z 7.5.1.2, 7.5.1.3
    • IBM Rational Developer for System z 7.6.1, 7.6.2, 7.6.2.1
    • ILOG ODM Enterprise v3.4
    • InfoSphere Data Architect 7.5.2.2, 7.5.3.0
    • Optim Database Administrator for DB2 for Linux, UNIX, and Windows 2.2.2.1, 2.2.3.0
    • Optim Query Tuner 2.2.0.2, 2.2.1.0
    • Rational Application Developer for WebSphere Software 7.5.5.1
    • Rational Business Developer 7.5.1.5
    • Rational Software Architect for WebSphere Software 7.5.5.1
    • Rational Software Architect RealTime Edition 7.5.5.1
    • Rational Software Architect Standard Edition 7.5.5.1
    • Rational Software Modeler 7.5.5.1
    • WebSphere Business Modeler v6.2.0.3
    • WebSphere Business Modeler v7.0.0.2
    • WebSphere Business Monitor v6.2.0.3
    • WebSphere Business Monitor v7.0.0.2
    • WebSphere Integration Developer v6.2.0.3
    • WebSphere Integration Developer v7.0.0.2
    • Rational Developer for Power Systems Software 7.6.0.1

Compatibility Group 8:
    • Rational Business Developer 7.5.1.6
    • Rational Application Developer for WebSphere Software 7.5.5.2
    • Rational Software Architect for WebSphere Software 7.5.5.2
    • Rational Software Architect RealTime Edition 7.5.5.2
    • Rational Software Architect Standard Edition 7.5.5.2
    • Rational Software Modeler 7.5.5.2
    • Rational Business Developer 7.5.1.6

Compatibility Group 9:
    • Rational Application Developer for WebSphere Software 7.5.5.3
    • Rational Software Architect for WebSphere Software 7.5.5.3
    • Rational Software Architect RealTime Edition 7.5.5.3
    • Rational Software Architect Standard Edition 7.5.5.3
    • Rational Software Modeler 7.5.5.3
    • IBM Optim Query Tuner 2.2.1.1
    • InfoSphere Data Architect 7.5.3.1
    • Warehouse Tooling 9.7.3
    • IBM Optim Database Administrator for DB2 for Linux, UNIX and Windows 2.2.3.1
    • IBM Optim Development Studio 2.2.1.1
    • InfoSphere Data Architect 7.6
    • Rational Business Developer 7.5.1.7

Compatibility Group 10:
    • Rational Application Developer for WebSphere Software 7.5.5.4
    • Rational Software Architect for WebSphere Software 7.5.5.4
    • Rational Software Architect RealTime Edition 7.5.5.4
    • Rational Software Architect Standard Edition 7.5.5.4
    • Rational Software Modeler 7.5.5.4
    • WebSphere Integration Developer 7.0.0.4
    • InfoSphere Data Architect 7.6
    • IBM Data Studio 3.1
    • Rational Business Developer 7.5.1.7

Compatibility Group 11:
    • Rational Application Developer for WebSphere Software 7.5.5.5
    • Rational Software Architect for WebSphere Software 7.5.5.5
    • Rational Software Architect RealTime Edition 7.5.5.5
    • Rational Software Architect Standard Edition 7.5.5.5
    • Rational Software Modeler 7.5.5.5
    • WebSphere Integration Developer 7.0.0.5
    • InfoSphere Data Architect 7.6
    • IBM Data Studio 3.1
    • Rational Business Developer 7.5.1.8


Additional Rational information on what is supported

Change History
Oct 7, 2015updated link for RTC 5.0.2 workaround
(originally: https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=364747)
Oct 1, 2015added RTC 6.0 to Java 7 compatibility group; was tested by RAD SVT as well as by RTC tea,
Sept 2015added IDE's 9.5 compatibility Group
05 June 2014added note about Eclipse 4.2.2 shell sharing
23 May 2014added a new combination, combined two combinations for Eclipse 4.2.2 based releases
10 March 2014added combination 2 for Eclipse 4.2.2 based releases
5 Dec 2013added combination 3 for Eclipse 3.6.x on Java 7 based releases
added combination 8 for Eclipse 3.6.x based releases
18 July 2013added combination 1 for Eclipse 4.2 based releases
Deleted products that are based on Eclipse 3.3 and 3.2 as they are no longer supported
27 May 2013Added RAM 7512 to Combination combination 2 for Eclipse 3.6 & Java 7 based releases
12 Dec 2012added combination 7 for Eclipse 3.6 based releases
26 Nov 2012added combination 2 for Eclipse 3.6 & Java 7 based releases
5 Jul 2011added combination 4 for Eclipse 3.6 based releases and 10 for Eclipse 3.4 based support
11 March 2011added combination 3 for Eclipse 3.6 based releases
17 December 2010added combination 2 for Eclipse 3.6 based releases and combination 9 for Eclipse 3.4 based releases
20 August 2010added combination 1 for Eclipse 3.6 based releases
20 April 2010added/ update combinations 2,3,4,5 for Eclipse 3.4 based releases
17 December 2009Provided more information on the limitations of shell sharing and provided some recommendations
23 February 2009Added link to Eclipse support information
12 March 2008Initial publication

[{"Product":{"code":"SSRTLW","label":"Rational Application Developer for WebSphere Software"},"Business Unit":{"code":"BU011","label":"Systems - zSystems software"},"Component":"General Information","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.5;8.5.1;8.5.5;8.5.5.1;8.5.5.2;8.5.5.3;9.0;9.0.1;9.0.1.1;9.0.1.2;9.1;9.1.0.1;9.1.1;9.1.1.1;9.5;9.5.0.1;9.5.0.2;9.6;9.6.1;9.6.1.1","Edition":""},{"Product":{"code":"SSUS84","label":"Rational Asset Manager"},"Business Unit":{"code":"BU011","label":"Systems - zSystems software"},"Component":"General information","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.1;7.1.0.1;7.1.1;7.1.1.1;7.2;7.2.0.1;7.2.0.2;7.5;7.5.0.1;7.5.0.2;7.5.1;7.5.1.1;7.5.1.2;7.5.2;7.5.2.1","Edition":""},{"Product":{"code":"SSXJ7E","label":"Rational Business Developer Extension"},"Business Unit":{"code":"BU011","label":"Systems - zSystems software"},"Component":" ","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7","Edition":""},{"Product":{"code":"SSJMXE","label":"Rational Functional Tester"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;8.0;8.0.0.1;8.0.0.2;8.0.0.3;8.0.0.4;8.1;8.1.0.1;8.1.0.2;8.1.0.3;8.1.1;8.1.1.1;8.1.1.2;8.1.1.3;8.2;8.2.0.1;8.2.0.2;8.2.1;8.2.1.1;8.2.2;8.2.2.1;8.3;8.3.0.1;8.3.0.2;8.5;8.5.0.1;8.5.1;8.5.1.1;8.5.1.2;8.5.1.3;8.6","Edition":""},{"Product":{"code":"SSCM5S","label":"Rational Manual Tester"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"6.1;6.1.0.1;6.1.1;6.1.1.1;7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7;7.0.1.8;7.0.1.9;7.0.1.10","Edition":""},{"Product":{"code":"SS5HXK","label":"Rational Modeling Extension for Microsoft .NET"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.10;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.0.9;7.0.5;7.0.5.1;7.0.5.2;7.0.5.3;7.0.5.4;7.5;7.5.1;7.5.2;7.5.3;7.5.4;7.5.5;7.5.5.1;7.5.5.2;7.5.5.3;7.5.5.4;7.5.5.5","Edition":""},{"Product":{"code":"SSMMM5","label":"Rational Performance Tester"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.1;7.0.1.1;7.0.1.2;7.0.2;7.0.2.1;7.0.2.2;7.0.2.3;8.0;8.0.0.1;8.0.0.2;8.0.0.3;8.0.0.4;8.1;8.1.0.1;8.1.0.2;8.1.0.3;8.1.1;8.1.1.1;8.1.1.2;8.2;8.2.0.1;8.2.0.2;8.2.0.3;8.2.0.4;8.2.0.5;8.2.0.6;8.2.1;8.2.1.1;8.2.1.2;8.2.1.3;8.2.1.4;8.2.1.5;8.3;8.3.0.1;8.3.0.2;8.3.0.3;8.5;8.5.0.1;8.5.0.2;8.5.1;8.5.1.1;8.5.1.2;8.5.1.3;8.6","Edition":""},{"Product":{"code":"SS8PJ7","label":"Rational Software Architect"},"Business Unit":{"code":"BU011","label":"Systems - zSystems software"},"Component":" ","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.0;8.0.1;8.0.2;8.0.3;8.0.4;8.0.4.1;8.0.4.2;8.5;8.5.1;8.5.5;8.5.5.1;9.0;9.0.0.1;9.1","Edition":"All Editions"},{"Product":{"code":"SSCLKU","label":"Rational Software Modeler"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.5;7.0.5.1;7.0.5.2;7.0.5.3;7.5;7.5.1;7.5.2;7.5.3;7.5.4;7.5.5;7.5.5.1;7.5.5.2;7.5.5.3;7.5.5.4;7.5.5.5","Edition":"All Editions"},{"Product":{"code":"SSJP3D","label":"Rational Systems Developer"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"PF016","label":"Linux"},{"code":"","label":" Windows"}],"Version":"6.0; 7.0","Edition":""},{"Product":{"code":"SSJM4G","label":"Rational Web Developer for WebSphere Software"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"6.0","Edition":""},{"Product":{"code":"SSBRLP","label":"WebSphere Studio Application Developer"},"Business Unit":{"code":"BU050","label":"BU NOT IDENTIFIED"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SS2MD7","label":"WebSphere Studio Site Developer"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":"DWE - Design Studio","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU050","label":"BU NOT IDENTIFIED"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SSBSK5","label":"Rational Method Composer"},"Business Unit":{"code":"BU005","label":"IoT"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU005","label":"IoT"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SS62YD","label":"IBM Data Studio"},"Business Unit":{"code":"BU050","label":"BU NOT IDENTIFIED"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SSSRXA","label":"Rational Data Architect"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":null,"Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"SSCP65","label":"Rational Team Concert"},"Business Unit":{"code":"BU011","label":"Systems - zSystems software"},"Component":null,"Platform":[{"code":"","label":""}],"Version":"","Edition":""},{"Product":{"code":"HWQQQ","label":"IBM InfoSphere Data Architect"},"Business Unit":{"code":"","label":""},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1;7.5.2","Edition":""},{"Product":{"code":"HWQQQ","label":"IBM Data Studio Developer"},"Business Unit":{"code":"","label":""},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.1","Edition":""},{"Product":{"code":"SS4RSW","label":"IBM Data Studio Administrator for DB2 for Linux- UNIX and Windows"},"Business Unit":{"code":"BU001","label":"Analytics Private Cloud"},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.1.0","Edition":""},{"Product":{"code":"SSK8TX","label":"InfoSphere Warehouse"},"Business Unit":{"code":"BU050","label":"BU NOT IDENTIFIED"},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.7.0","Edition":""},{"Product":{"code":"SSSQRS","label":"Optim Development Studio"},"Business Unit":{"code":"BU001","label":"Analytics Private Cloud"},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.2","Edition":""},{"Product":{"code":"SSSQUJ","label":"Optim Database Administrator for DB2 for Linux- UNIX and Windows"},"Business Unit":{"code":"BU001","label":"Analytics Private Cloud"},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.2","Edition":""},{"Product":{"code":"HWQQQ","label":"Optim Query Tuner for DB2 for Linux- UNIX and Windows"},"Business Unit":{"code":"","label":""},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.2","Edition":""},{"Product":{"code":"SS4JCV","label":"Rational Software Architect for WebSphere Software"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.5;7.5.1;7.5.2;7.5.3;7.5.4;7.5.5","Edition":"All Editions"},{"Product":{"code":"SS5JSH","label":"Rational Software Architect RealTime Edition"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5.2;7.5.3;7.5.4;7.5.5","Edition":"All Editions"},{"Product":{"code":"SS4JE2","label":"Rational Software Architect Standard Edition"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":null,"Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.5;7.5.1;7.5.2;7.5.3;7.5.4;7.5.5","Edition":"All Editions"}]

Document Information

Modified date:
23 June 2018

UID

swg21279139