IBM Support

OpenSSL 0.9.8 is removed in 7200-05-07

Notification


Risk classification

Informational

Risk categories

Function Loss

Subcategories for Informational notifications

Troubleshooting & Fixes

Abstract

OpenSSL 0.9.8 shared objects are removed from AIX 7.2 libcrypto.a and libssl.a in 7200-05-07. The compat libraries (libcrypto_compat.a and libssl_compat.a) are also removed.
The command line tools openssl and openssl64 are rebuilt with OpenSSL 3.0 in 7200-05-07.
IBM recommends ensuring the following prior to updating to AIX 7200-05-07:
- applications are not dependent on OpenSSL 0.9.8 shared objects
- No legacy algorithms such as MD2, blowfish are used as arguments for openssl command line.
See the 7200-05 release notes for more information.

Date first published

10 November 2023

[{"Risk Classification":"Informational","Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG10","label":"AIX"},"ARM Category":[{"code":"a8m0z000000cvzvAAA","label":"AIX Open Source-\u003EOPENSSH\/OPENSSL"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.2.0"}]

Document Information

Modified date:
10 November 2023

UID

ibm17069236