Troubleshooting
Problem
During NIMADM migration, clients managed by HMC might fail and get the following error.
{opslab171} # nimadm -c opslab108 -l AIX-7300-01-01-2246-lpp -s AIX-7300-01-01-2246-spot -d hdisk2 -Y
Initializing the NIM master.
Initializing NIM client opslab108.
0042-001 nim: processing error encountered on "master":
0042-525 m_ckmac: Wrong login/password ; check the passwd_file attribute of the dsolab101 object.
0505-213 nimadm: ATTENTION, nim returned an unexpected result.
Cleaning up alt_disk_migration on the NIM master.
Symptom
If we run nim -Fo check <Client> against the failed client, we get a similar error.
# nim -Fo check opslab108
0042-001 nim: processing error encountered on "master":
0042-525 m_ckmac: Wrong login/password ; check the passwd_file attribute of the dsolab101 object.
Cause
When a nimadm is run against a client that is managed by HMC. It calls for nim -Fo check command and it checks the client status by asking the HMC. If the CEC definition for the client is wrong, it shows the error "0042-525 m_ckmac: Wrong login or password; check the passwd_file attribute of the <HMC_NAME> object" even if the password in the pswd file is correct.
Environment
AIX
Diagnosing The Problem
First, we need to verify the HMC password if the password file is correct. From NIM, ssh to the HMC and make sure that the password is valid. If the password needs to be changed in the password file, overwrite the password file with the correct HMC password by using the following command.
#dpasswd -f /export/nim/dsm/passwd/dsolab101.pswd -o -P <HMC password> -U hscroot
Password file is /export/nim/dsm/passwd/dsolab101.pswd
Password file overwritten
Now check the CEC definition of the Client from NIM.
# lsnim -c management
dsolab101 management hmc
9080-M9S_FWM0001 management cec
# lsnim -l 9080-M9S_FWM0001
9080-M9S_FWM0001:
class = management
type = cec
serial = 9080-M9S*218452W <<<<<<<<<
hmc = dsolab101
manages = opslab108
Cstate = ready for a NIM operation
# lsnim -l opslab108
opslab108:
class = machines
type = standalone
connect = nimsh
platform = chrp
netboot_kernel = 64
if1 = nim_network opslab108 0
cable_type1 = N/A
mgmt_profile1 = dsolab101 7 9080-M9S_FWM0001 <<<<<<<<
Cstate = ready for a NIM operation
prev_state = ready for a NIM operation
Mstate = currently running
cpuid = 00F93E124B00
Cstate_result = reset
Note down the Machine Type and model from the CEC definition on NIM
Go to client run prtconf and compare both. You can also check the details from HMC GUI.
By comparing the outputs, we can see that the System Model and Machine serial numbers are wrong in the CEC definition on NIM and we need to fix that.
Go to client run prtconf and compare both. You can also check the details from HMC GUI.
#hostname
opslab108
#prtconf
System Model: IBM,9009-42A
Machine Serial Number: 213E12V
Processor Type: PowerPC_POWER9
Processor Implementation Mode: POWER 9
First check if the Correct CEC definition for the client is already there in NIM. If not, define it using correct machine details. If the CEC definition is there but have wrong machine model or serial number, then remove the definition and define it correctly By comparing the outputs, we can see that the System Model and Machine serial numbers are wrong in the CEC definition on NIM and we need to fix that.
Resolving The Problem
Remove the wrong CEC
#nim -Fo remove 9080-M9S_FWM0001
Define the CEC for client with the correct Serial Number and System Model.
cli:
#nim -o define -t cec -a hw_serial=213E12V -a hw_type=9009 -a hw_model=42A -a mgmt_source=dsolab101 9009_42A_213E12V
smit:
#smit nim_mkmgmt_obj >Select CEC
* Management Object Name [9009_42A_213E12V]
* Hardware Platform Type [9009]
* Hardware Model [42A]
* Hardware Serial [213E12V]
* Management Source [dsolab101]
If the correct CEC for the client is already there in NIM or once the CEC is defined correctly, we can update it to the client by using nim_chmac command.
Run smitty nim_chmac > Select the client opslab108
Correct the CEC details in the "Management Source" entry.
Run smitty nim_chmac > Select the client opslab108
Correct the CEC details in the "Management Source" entry.
Change/Show Characteristics of a Machine
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
Machine Name [opslab108]
* Hardware Platform Type [chrp] +
* Kernel to use for Network Boot [64] +
Machine Type standalone
Network Install Machine State currently running
Network Install Control State ready for a NIM operation
Primary Network Install Interface
Network Name nim_network
Host Name [opslab108]
Network Adapter Hardware Address [0]
Network Adapter Logical Device Name [ent]
Cable Type bnc
CPU Id [00F93E124B00]
Communication Protocol used by client [nimsh] +
NFS Client Reserved Ports [] +
Comments []
Managing System Information
LPAR Options
Identity [7]
Management Source [9009_42A_213E12V] <<<<<<<<<
Now first, we can run nim -Fo check. We can see that there is no error after fixing the CEC definition.
# nim -Fo check opslab108
Now NIMADM should be working correctly.
{opslab171} # nimadm -c opslab108 -l AIX-7300-01-01-2246-lpp -s AIX-7300-01-01-2246-spot -d hdisk2 -Y
Initializing the NIM master.
Initializing NIM client opslab108.
Verifying alt_disk_migration eligibility.
Initializing log: /var/adm/ras/alt_mig/opslab108_alt_mig.log
Starting Alternate Disk Migration.
+-----------------------------------------------------------------------------+
Executing nimadm phase 1.
+-----------------------------------------------------------------------------+
Cloning altinst_rootvg on client, Phase 1.
Related Information
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Document Information
Modified date:
15 November 2023
UID
ibm17061999