Question & Answer
Question
On our system we see that the QCTXDMON Transform Services job loops and takes a high amount of CPU. How can we resolve this?
Cause
One common cause of this issue is that the Transform Services work directories are being saved or replicated while the product is trying to create PDFs.
Answer
The Transform Services work directories do not contain any information that need to be saved. They are used only for work performed by Transform Services as it is running. To prevent the work directories from being saved, such as by a Save While Active operation, running the following commands to specify that the IFS folders used by Transform Services are not saved:
CHGATR OBJ('/QOpenSys/QIBM/UserData/TransformServices') ATR(*ALWSAV) VALUE(*NO) SUBTREE(*ALL)
CHGATR OBJ('/QOpenSys/QIBM/UserData/TransformServices/work') ATR(*ALWSAV) VALUE(*NO) SUBTREE(*ALL)
If you're using a software replication process, remove the /TransformServices and /TransformServices/work directories from being replicated. Instructions for that will vary based on the product you are using (Mimix, DataMirror, etc).
CHGATR OBJ('/QOpenSys/QIBM/UserData/TransformServices') ATR(*ALWSAV) VALUE(*NO) SUBTREE(*ALL)
CHGATR OBJ('/QOpenSys/QIBM/UserData/TransformServices/work') ATR(*ALWSAV) VALUE(*NO) SUBTREE(*ALL)
If you're using a software replication process, remove the /TransformServices and /TransformServices/work directories from being replicated. Instructions for that will vary based on the product you are using (Mimix, DataMirror, etc).
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Document Information
Modified date:
06 October 2023
UID
ibm17047726