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QRadar: Error in Auto Update log: Could not download dau//feeds/7.3/remotenet.conf.gz.

Troubleshooting


Problem

After Auto Updates run, this message appears in the dashboard, "Automatic updates installed with errors".

Symptom

Look at the Auto Update log in the User Interface.  In the browser, go to the Admin tab, click Auto Update.  Then, click View Log
Some or all of these errors appear in the log:
[ERROR] Could not download dau//feeds/7.3/remotenet.conf.gz.
[INFO] /store/autoupdates/dau//feeds/7.3/remotenet.conf.gz. doesn't exist!

[ERROR] Could not download dau//feeds/7.3/supportability-tools.rpm.gz.
[INFO] /store/autoupdates/dau//feeds/7.3/supportability-tools.rpm.gz doesn't exist!

[ERROR] Could not download dau//feeds/7.3/supportability-data.rpm.gz.
[INFO] /store/autoupdates/dau//feeds/7.3/supportability-data.rpm.gz doesn't exist!

[ERROR] Could not download wau/configuration/7/signatures.xml.gz.
[INFO] /store/autoupdates/wau/configuration/7/signatures.xml.gz doesn't exist!

[ERROR] Could not download wau/configuration/7/geodata.conf.gz.
[INFO] /store/autoupdates/wau/configuration/7/geodata.conf.gz doesn't exist!

[ERROR] Could not download wau/configuration/7/socialnet.list.gz.
[INFO] /store/autoupdates/wau/configuration/7/socialnet.list.gz doesn't exist!

Cause

The cause varies depending upon the information found in the "Diagnosing the problem" section.

Diagnosing The Problem

To diagnose the problem, follow these steps:
1.  To see whether the folders exist in a command line on the server, type:
cd /store/autoupdates/dau/feeds/7.3/
cd /store/autoupdates/wau/configuration/7/
If the command completes successfully, go to the next step.
If the command fails, go to the Resolving the Problem section.
Failed command:
cd /store/autoupdates/dau/feeds/7.3/
-bash: cd: /store/autoupdates/dau/feeds/7.3/: No such file or directory

cd /store/autoupdates/wau/configuration/7/
-bash: cd: /store/autoupdates/wau/configuration/7/: No such file or directory
2.  To determine whether the problem is connecting to the servers, if an http proxy server is not in use, then run the following commands:
cd /storetmp
wget "https://auto-update.qradar.ibmcloud.com/autoupdates/dau//feeds/7.3/remotenet.conf.gz"
wget "https://auto-update.qradar.ibmcloud.com/autoupdates/dau//feeds/7.3/supportability-tools.rpm.gz"
wget "https://auto-update.qradar.ibmcloud.com/autoupdates/dau//feeds/7.3/supportability-data.rpm.gz"
If the commands fail to download the files, then refer to section B in diagnosing the problem.

Resolving The Problem

A.  If the cd commands from the diagnosing the problem fail, then follow step 1.  
1. Create the folders directly by running these commands as root so that they have the correct ownership:
mkdir -p /store/autoupdates/dau/feeds/7.3/
mkdir -p /store/autoupdates/wau/configuration/7/

2. Once the directories are created, the nightly auto updates should run without these errors.

B.  If the wget commands fail to connect, resolve any error messages listed.  If there is not enough detail listed to resolve, enable verbose debug in the command by adding the -vvv entry.  For example,:

wget -vvv "https://auto-update.qradar.ibmcloud.com/autoupdates/dau//feeds/7.3/remotenet.conf.gz"

If you continue to experience issues or error messages related to the problem in this document, contact QRadar Support.

Document Location

Worldwide

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Document Information

Modified date:
29 September 2023

UID

ibm17033073