Troubleshooting
Problem
While updating to update the firmware of your QRadar hardware appliance, the update could fail in the Lenovo XClarity Essentials UpdateXpress tools with the following error: Error(s) occur while comparing! Error message: Failed to get system info
Symptom
The Update Recommendation screen displays as Error(s) occur while comparing! Error message: Failed to get system info
Cause
The bootable UpdateXpress tool communicates internally through the hardware to communicate to the BMC in order to retrieve the component firmware levels. This communication is done to compare the installed firmware levels to the levels in the update so that the components that require updates can be selected and updated.
When this error occurs, the UpdateXpress tool is not able to communicate to the BMC. With no communications, the installed levels cannot be checked, and it also means the UpdateXpress tool cannot send firmware updates through the BMC to update the individual components.
Resolving The Problem
In some circumstances, Ethernet Over USB settings can cause issues with the UpdateXpress communicating to the BMC.
Technote: QRadar: How to determine the status of LAN Over USB on SystemX® and ThinkSystem™ appliances, provides steps to check and correct settings to allow communications.
If those settings are correct and you are still experiencing the issue, there is an option in the UpdateXpress tool to allow the tool to communicate to the BMC through the CIM and REST ports.
- On the Update Recommendation screen, click the Previous button.
- From the Settings menu, click the check box of Input BMC access information.
- Type the BMC/XCC Username and Password, as well as the CIM Port and REST Port.
- The default CIM Port for the BMC is 5989, and the REST Port is 443. To confirm that these port numbers are correct for your host, and to ensure the ports are enabled, log in to the XCC (OEM Controller) Browser UI.
- From the left side navigation menu, go to BMC Configuration, then Network settings.
- You can either click Service Port in the right side navigation panel or scroll down to Service Enablement and Port Assignment.
- Verify the REST Over HTTPS port number and the CIM Over HTTPS port number, and confirm that both ports are Enabled.
- After the ports are verified and enabled in the Lenovo XClarity Essentials UpdateXpress tool, click Next.
- Click Begin to start your firmware update.
- The UpdateXpress tool is expected to communicate to the BMC to retrieve the installed firmware levels and is able to push the new component updates through the BMC.
- You can now return to the normal firmware update process. The next screen will show installed firmware levels, compare them to the firmware levels contained in the bootable ISO, and select the components that can be upgraded.
- After the firmware updates are selected, click Next to start the firmware update process.
Results
The firmware is expected to complete normally. If you experience issues with this error message or continue to experience issues, confirm the port information or contact QRadar Support.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
21 September 2023
UID
ibm17032086