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Cloud Pak for Security: Reinstall failed with error failed to install common services catalog

Troubleshooting


Problem

Reinstalling Cloud Pak for Security receives "[ERROR] Failed to install Common services catalog". 

Symptom

+ cloudctl case launch --case ibm-cp-security --namespace ibm-common-services --inventory ibmCommonServiceOperatorSetup --action install-catalog --args '--registry quay.io' --tolerance 1
+ err_exit 'Failed to install Common services catalog'
+ echo '[ERROR] Failed to install Common services catalog'
[ERROR] Failed to install Common services catalog

Cause

When reinstalling Cloud Pak for Security, the secrets configuration was not removed from the initial installation.

Diagnosing The Problem

It's possible that the older secret was not properly removed:
  1. Locate your "icp-management-ingress-tls-secret" secret under namespace IBM-common-services:
     oc get secret icp-management-ingress-tls-secret -n ibm-common-services
    Example output:
    NAME                                TYPE                DATA   AGE
    icp-management-ingress-tls-secret   kubernetes.io/tls   3      23d
  2. Record the timestamp.
  3. Verify whether there is a duplicate newer secret.

Resolving The Problem

  1. Remove the old secret:
    oc delete secret/icp-management-ingress-tls-secret -n ibm-common-services
  2. Reinstall Cloud Pak for Security.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m0z0000001h8uAAA","label":"Cloud Pak for Security (CP4S)-\u003EInstall or Upgrade"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
02 October 2023

UID

ibm17028885